5.8 Full Screen Mode ................................................................. - 49 -

6 Using the LogWorks Main Dashboard ................................................................. - 50 -
   6.1 Connecting to the MTS Log Chain ............................................................. - 50 -
   6.2 Real time logging ....................................................................................... - 50 -
      6.2.1 Triggered Real time Logs ................................................................. - 51 -
   6.3 Real time Math channels ........................................................................... - 55 -
   6.4 Viewing existing log Files ......................................................................... - 56 -
   6.5 Downloading existing log Files .................................................................. - 56 -
      6.5.1 Downloading LM-1 data ................................................................... - 56 -
      6.5.2 Downloading SD-card (LM-2 or DL-32) data .................................... - 57 -
   6.6 Selecting Representation of the Mixture .................................................. - 58 -
   6.7 And Further .............................................................................................. - 58 -
      6.7.1 LogWorks Main Window Menu ....................................................... - 58 -
      6.7.2 Help Menu ....................................................................................... - 58 -

7 Working with Logs and Sessions ......................................................................... - 59 -
   7.1 The Log Window ....................................................................................... - 59 -
   7.2 Navigating Logs ....................................................................................... - 61 -
      7.2.1 Changing the size of the Panes ......................................................... - 61 -
      7.2.2 Navigating Sessions ......................................................................... - 61 -
      7.2.3 Scrolling in the Time Axis .............................................................. - 61 -
      7.2.4 Zooming in and out in the Time Scale ............................................. - 62 -
      7.2.5 Measuring ......................................................................................... - 62 -
      7.2.6 Identifying Channels ......................................................................... - 63 -
      7.2.7 Marker Lines ..................................................................................... - 63 -
   7.3 Manipulating channel traces ...................................................................... - 64 -
      7.3.1 The scale pane ................................................................................... - 64 -
      7.3.2 Zooming in and out on a channel trace .......................................... - 65 -
      7.3.3 Smoothing channels ......................................................................... - 65 -
      7.3.4 Hiding/Showing channels ............................................................... - 66 -
      7.3.5 Deleting channels ........................................................................... - 66 -
      7.3.6 Configuring Channels ...................................................................... - 67 -
      7.3.7 Math Channels .................................................................................. - 67 -
      7.3.8 Channel Templates ......................................................................... - 67 -
   7.4 Selecting areas in a Session ...................................................................... - 69 -
      7.4.1 Inverting a selection ......................................................................... - 69 -
      7.4.2 Auto Selecting and Searching ....................................................... - 69 -
      7.4.3 Scanning through selected areas ................................................... - 71 -
   7.5 Working with Sessions ............................................................................ - 72 -
      7.5.1 Changing session information ....................................................... - 72 -
      7.5.2 Notes and comments ...................................................................... - 72 -
      7.5.3 Deleting a whole Session or parts of a session ............................... - 73 -
      7.5.4 Copying and Pasting ...................................................................... - 75 -
      7.5.5 Overlays .......................................................................................... - 75 -
   7.6 Saving, exporting and Printing .................................................................. - 76 -
      7.6.1 Exporting to different file formats ................................................ - 76 -
      7.6.2 Printing Logs .................................................................................. - 77 -
   7.7 Alternate Views of Sessions and Logs ...................................................... - 78 -
      7.7.1 Playback ......................................................................................... - 78 -
      7.7.2 Statistics Views ............................................................................... - 79 -
      7.7.3 Opening X-Y Plot Views ............................................................... - 80 -
      7.7.4 Opening 3D charts ......................................................................... - 81 -

8 X-Y Plots ......................................................................................................... - 83 -
   8.1 Selecting the channels to plot ................................................................. - 84 -
      8.1.1 XY - Templates ............................................................................. - 85 -
   8.2 Selecting the data to show ....................................................................... - 85 -
   8.3 X-Y Plot representation ........................................................................... - 86 -
      8.3.1 Scatter Plot ..................................................................................... - 86 -
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>8.3.2 Line Plot</td>
<td>86</td>
</tr>
<tr>
<td>8.3.3 Text Table View</td>
<td>87</td>
</tr>
<tr>
<td>8.4 Zooming and scrolling the view</td>
<td>88</td>
</tr>
<tr>
<td>8.4.1 Increasing the axis resolution</td>
<td>88</td>
</tr>
<tr>
<td>8.4.2 Reducing the axis resolution</td>
<td>88</td>
</tr>
<tr>
<td>8.4.3 Scrolling</td>
<td>88</td>
</tr>
<tr>
<td>8.4.4 Auto scaling the x-axis</td>
<td>88</td>
</tr>
<tr>
<td>8.5 Marker Lines</td>
<td>89</td>
</tr>
<tr>
<td>8.6 Min Max Info</td>
<td>89</td>
</tr>
<tr>
<td>8.7 Channel Identification</td>
<td>90</td>
</tr>
<tr>
<td>8.8 Polar Coordinates</td>
<td>90</td>
</tr>
<tr>
<td>8.8.1 Marker Lines in Polar View</td>
<td>91</td>
</tr>
<tr>
<td>8.8.2 Interpretation example of Polar View</td>
<td>92</td>
</tr>
<tr>
<td>9 3D charts and graphs</td>
<td>93</td>
</tr>
<tr>
<td>9.1 The 3D chart window</td>
<td>93</td>
</tr>
<tr>
<td>9.2 Selecting data to base the chart on</td>
<td>94</td>
</tr>
<tr>
<td>9.2.1 Locking a chart</td>
<td>94</td>
</tr>
<tr>
<td>9.3 Manipulating the chart settings</td>
<td>95</td>
</tr>
<tr>
<td>9.3.1 Adding a column or row</td>
<td>95</td>
</tr>
<tr>
<td>9.3.2 Changing row or column header values</td>
<td>95</td>
</tr>
<tr>
<td>9.3.3 Copying/pasting row and column settings</td>
<td>95</td>
</tr>
<tr>
<td>9.3.4 Changing the Chart channels</td>
<td>96</td>
</tr>
<tr>
<td>9.3.5 Deleting rows or columns</td>
<td>97</td>
</tr>
<tr>
<td>9.4 Chart Templates</td>
<td>97</td>
</tr>
<tr>
<td>9.5 Colorizing a chart</td>
<td>98</td>
</tr>
<tr>
<td>9.6 User sub-charts</td>
<td>99</td>
</tr>
<tr>
<td>9.6.1 Creating a user sub-chart</td>
<td>99</td>
</tr>
<tr>
<td>9.6.2 Entering data in a user sub-chart</td>
<td>99</td>
</tr>
<tr>
<td>9.6.3 Deleting user chart entries</td>
<td>99</td>
</tr>
<tr>
<td>9.6.4 Filling in user data quickly</td>
<td>100</td>
</tr>
<tr>
<td>9.6.5 Blending ranges</td>
<td>100</td>
</tr>
<tr>
<td>9.7 Exchanging chart data with other programs</td>
<td>101</td>
</tr>
<tr>
<td>9.7.1 Exporting chart data</td>
<td>101</td>
</tr>
<tr>
<td>9.7.2 Copying and pasting chart data</td>
<td>101</td>
</tr>
<tr>
<td>9.8 Overlaying charts</td>
<td>101</td>
</tr>
<tr>
<td>9.9 Viewing a sub-chart as 3D-graph</td>
<td>103</td>
</tr>
<tr>
<td>9.9.1 Manipulating the graph view</td>
<td>106</td>
</tr>
<tr>
<td>9.9.2 Glyphs</td>
<td>106</td>
</tr>
<tr>
<td>9.9.3 Overlays on 3D graphs</td>
<td>107</td>
</tr>
<tr>
<td>9.10 Calculations with charts</td>
<td>108</td>
</tr>
<tr>
<td>9.11 Realtime indication in the chart and graph (Map tracing)</td>
<td>109</td>
</tr>
<tr>
<td>9.12 Some tips on working with charts</td>
<td>109</td>
</tr>
<tr>
<td>10 Math Trace Calculator</td>
<td>111</td>
</tr>
<tr>
<td>10.1 Calculator basics</td>
<td>112</td>
</tr>
<tr>
<td>10.2 Asking for user data</td>
<td>113</td>
</tr>
<tr>
<td>10.3 Restrictions on variable names</td>
<td>114</td>
</tr>
<tr>
<td>10.4 Using LogWorks channels</td>
<td>114</td>
</tr>
<tr>
<td>10.5 Calculating new LogWorks channels</td>
<td>116</td>
</tr>
<tr>
<td>10.5.1 Creating calculated value channels</td>
<td>116</td>
</tr>
<tr>
<td>10.5.2 Calculating new bit channels</td>
<td>117</td>
</tr>
<tr>
<td>10.6 Dealing with units</td>
<td>119</td>
</tr>
<tr>
<td>10.7 Formula Calculator Functions</td>
<td>120</td>
</tr>
<tr>
<td>10.8 Chart Calculator</td>
<td>122</td>
</tr>
<tr>
<td>10.8.1 Pre-assigned names for the standard sub-charts</td>
<td>122</td>
</tr>
<tr>
<td>10.8.2 Using the Chart Calculator</td>
<td>122</td>
</tr>
<tr>
<td>11 LogWorks Libraries</td>
<td>124</td>
</tr>
<tr>
<td>11.1 Using the Libraries</td>
<td>124</td>
</tr>
</tbody>
</table>
1 Overview

LogWorks is a software application that interfaces with the Innovate Modular Tuning System products. It enables easy analysis and manipulation of engine data acquired by MTS components and also allows to view engine data in real-time on the on-screen virtual gauges.

This manual describes the basics of data logging with the Innovate Modular Tuning System and how to use the LogWorks 3.0 Program. In addition this manual shows how you can extend the capabilities of the MTS with some basic electronic skills.

1.1 Specifications

Computer Requirements

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating System</td>
<td>Windows 98 or later</td>
</tr>
<tr>
<td>Computer speed</td>
<td>600MHz Pentium 1 or faster</td>
</tr>
<tr>
<td>RAM</td>
<td>Min. 100 Mbyte more than recommended for the operating system</td>
</tr>
<tr>
<td>Hard Disk space</td>
<td>Min. 100 Mbyte free space</td>
</tr>
<tr>
<td>Display</td>
<td>Thousands of colors, 800 x 600 Min.</td>
</tr>
<tr>
<td>Other</td>
<td>1 free serial port or USB to serial adapter</td>
</tr>
</tbody>
</table>

LogWorks 3 Limits

<table>
<thead>
<tr>
<th>Limit</th>
<th>Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Max. Session Size</td>
<td>1 hr 30 minutes</td>
</tr>
<tr>
<td>(65536 sample sets at 0.08192 sec/set)</td>
<td></td>
</tr>
<tr>
<td>Max. Number of sessions per log</td>
<td>1024</td>
</tr>
<tr>
<td>Max. Number of logs open</td>
<td>32 open concurrently</td>
</tr>
<tr>
<td>Max. Number of value channels</td>
<td>64</td>
</tr>
<tr>
<td>Max. Number of bit channels</td>
<td>32</td>
</tr>
<tr>
<td>Max. Number of channels total</td>
<td>96</td>
</tr>
</tbody>
</table>
1.2 Manual Conventions

1.2.1 Important Info Marker

In this Manual important info and notes are highlighted with a important info marker.

1.2.2 Menu Selection Terminology

Menu Selections of a Window are shown as

Main Item->Item->Sub Item

Example selecting the Sub-Menu item “bold” in this menu:

Colors/Skins->Digit Style->bold

Would be shown as:

Colors/Skins->Digit Style->bold

If the menu item to select is variable, for example the name of a session or channel, the actual item name is shown in bold and italics

Sessions

In this case it would be shown as Sessions->Session Name.
1.3 Manual Overview

This manual is divided into chapters and is to be used both as a tutorial on how to use LogWorks as well as a reference handbook for the LogWorks program.

Chapter 1
Is the Overview you are reading.

Chapter 2
Explains the basics of data logging, channels, sessions and logs and what files LogWorks uses.

Chapter 3
Deals with Starting up LogWorks and shows the initial view of the LogWorks Main Dashboard.

Chapter 4
Explains channel configuration in LogWorks in detail.

Chapter 5
Explains LogWorks gauges and their setup and manipulation.

Chapter 6
Explains the functions available in the LogWorks Main Dashboard.

Chapter 7
Explains how to deal with logs and sessions and explains the analyzing functions available in the main log window.

Chapter 8
Explains the X-Y Plot view of data. This is a view of channel data plotted against another channel.

Chapter 9
Explains the 3D chart view of data. This is a view of channel data plotted or analyzed against two other channels. For example air-fuel against RPM and MAP. This chapter is important for creating fuel and spark tables.

Chapter 10
Explains the Math Engine in LogWorks used to mathematically analyze the data or create new math channels.

Chapter 11
Describes the built-in formulas of LogWorks to be used with the math engine.

Chapter 12
Describes the Plug-in architecture to extend the functionality of LogWorks.

Chapter 13
Explains the unit conversion mechanism of LogWorks.

Chapter 14
Shows Tips and Tricks in using LogWorks

Chapter 15
Shows how to interface to various sensors.

Chapter 16
Revision History
1.4 LogWorks Overview

1.4.1 LogWorks Data Views

The LogWorks application is used to record, display and analyze engine or car data. Natively it provides six different “views” of the data:

1. **Main Dashboard**
   This view displays the current engine data (real-time data) in “gauges”. Similar to a car’s dashboard. The gauges are configurable in many ways. This view is active whenever LogWorks receives engine data, whether the data is being logged or not.

2. **Time Trace Log View**
   This is the main view of a datalog. A datalog is a collection of engine data, sorted by recording time. The data in the Time Trace Log View (Log Window) is shown graphically and can be analyzed in many ways. During recording with LogWorks this view is updated automatically as new data arrives.

3. **Playback View**
   This is a sub-view of the Time-Trace Log View when the log is played back. This view is similar to the Main Dashboard View, but shows the recorded engine data in it’s time sequence when playing back.

4. **X-Y Plot View**
   In this View the logged engine data is shown in its dependency of another channel. A common example is to plot AFR as dependent on RPM. But any channel data combination can be used. The X-Y Plot view also allows viewing and analyzing the data in different ways. This view is NOT automatically updated during recording.

5. **3D Chart View**
   In this View the logged engine data is analyzed and shown in its dependency of two other channels. A common example is to show AFR data as dependent on RPM and engine load. But any channel combination can be used. This view sorts the engine data into different fields. The spacing and number of field columns and rows is user adjustable so it for example fits the spacing and number of how a fuel injection’s fuel tables are stored. This view is automatically updated during recording and provides many analyzing functions.

6. **Channel Statistics View**
   In this view a single channel is analyzed and its statistical distribution during a recording session is shown. This view is NOT automatically updated during recording.

1.4.2 LogWorks Plug-ins

LogWorks 3 can be extended with plug-ins. A plug-in is a piece of computer code or program that extends the functionality of LogWorks. Innovate provides some plug-ins for 3rd party products as examples, but 3rd parties can also provide plug-ins for LogWorks. The LogWorks SDK document describes how to create a plug-in.

LogWorks allows functionally 5 different types of plug-ins. A plug-in module does not have to be of a single type, but can provide the functional equivalent of multiple types.
LogWorks plug-in types:

1. **Acquisition Plug-ins**
   This plug-in type provides real-time engine data from another type of interface, e.g. not an Innovate device. An example is a plug-in that reads OBDII data from an OBDII interface for a factory ECU and feeds that data to LogWorks, or a plug-in for an aftermarket ECU or piggyback to data log that devices data. The only restriction for Acquisition plug-ins is that at least ONE Innovate MTS device MUST be connected to the computer and is providing real time data.

2. **Real Time Channel Processor Plug-ins**
   This type of plug-in uses real-time engine data recorded from innovate MTS devices or Acquisition Plug-ins to either filter or modify the recorded data, or create a new recording channel filled with the results of computing new data from existing engine data. An example of this might be a plug in to convert a torque input channel and RPM information into a real time HP channel.

3. **Channel Processor Plug-ins**
   This type of plug-in operates similar to a real time channel plug-in, but operates on a whole recorded data session or data log. These plug-ins can be used to analyze the engine data in a way not provided by LogWorks, show different views of the data not provided by LogWorks or modify the recorded data, show “out-of-band” data that was captured concurrently with the data log, but not stored as part of it. Examples would be GPS data for track mapping, or video data from a video recording.

4. **Chart Source Plug-ins**
   These are very simple plug-ins. A chart source has to do only one thing: Provide chart column and row spacing data. A chart source plug-in for example could download column and row spacing information from an ECU so a LogWorks chart matches the ECU tables.

5. **Chart Processor Plug-ins**
   A chart processor Plug-in can be used to, but is not restricted to:
   a. Process chart data for example to create a new fuel table
   b. Provide a different view of the chart data
   c. Retrieve the current fuel table from the ECU, modify it based on data from the data log and write it back.
   d. Whatever the programmer can think of to do with charts.
2 Logging engine data

2.1 Data logging 101

Data logging is basically the recording of engine data. Engine data is measured with various sensors. Two types of logging are common.

- Time based logging
- RPM based logging

In time based logging the sensor data is read in fixed time intervals. This is similar to how a movie projector or a TV works. In a movie, a snapshot of the camera scene is taken 24 times per second. Because of the limited speed of the human eye, these snapshots, when viewed at the same sample rate of 24 snapshots per second, seem like continuous motion to the human eye.

Time based data logging works the same way. A snapshot of the engine state is recorded at fixed time intervals.

RPM based logging is mainly used in conjunction with chassis- or engine-dynamometers. Their purpose is to measure power and torque curves of an engine in relation to RPM. Typical RPM interval is every 50 RPM. Although this serves its purpose, time-dependent dynamic effects can’t be analyzed with this logging method.

A time based recording can be converted into an RPM based recording (LogWorks has that capability), but an RPM based recording can’t be converted back into a time based recording.

2.1.1 Definitions

- **Channel**
  A channel is the data from a single sensor, like AFR or RPM.

- **Sample**
  A snapshot of the engine state is called a sample. A sample can contain the data of many channels, but they are all measured ideally at the same time.

- **Sample Rate**
  The sample rate is the number of samples (snapshots) of engine data taken per second.

- **Channel Rate**
  The channel rate is the number of total channel measurements taken per second. It is the number of sensors measured for each sample multiplied by the sample rate.

2.1.2 Logging rate

The data logging rate or speed (samples per second) is dependent on what data is to be logged. When logging engine data, 99% of the data changes no faster than about 5 times per second (one state to another and back).
The engine state is ultimately controlled by the driver's right foot. The fastest external muscle in humans is the eye-lid muscle. It goes through one blink-cycle in about 100 milliseconds.

A mathematician named Harry Nyquist found out (in 1928), that for anything that you want to record, you only need to record at twice the maximum frequency contained in the recorded signal. So, for the human eye-lid, the required minimum logging speed is 20 times/second. The human foot, controlling a gas pedal, is much slower. Remember, the frequency is not measured from idle to WOT, but from idle to WOT and back.

The second parameter determining the logging speed is the statistical nature of the combustion process itself. No two combustion events in an engine are identical. Therefore, to get meaningful data, multiple combustion events must be averaged to see the overall effects. If each combustion event is analyzed and recorded, meaningful tuning data can't be seen in most cases. At 6000 RPM an engine goes through 50 engine cycles per second (a 4-stroke engine cycle requires two rotations per cycle). At a logging speed of 12.5 samples per second this would mean that the resulting data is the average of 4 engine cycles.

The above means that data logging engine data needs to be done at 10-15 samples per second. Anything more creates only more data points which do not contain any additional information, but are harder to analyze.

The Innovate Modular Tuning System samples engine data at 12.2 samples/second.

⚠️ This sample rate is the rate for a sample containing multiple sensor data, each sampled at the same time instance, NOT the total channel rate.

When evaluating data-logging products be very aware of the difference between channel rate and sample rate. Many manufacturers specify the channel rate, but claim it as sample rate. For example if a data logging system records 30 data channels, but reads each in turn only once per second, the channel rate is 30 per second, but the sample rate is only 1 per second.

This is especially problematic if the channels are not sampled at the same instance in time, but at whenever it is the turn for this channel to be read. The channel data, when taken and interpreted as sample, do not correlate anymore, because each reflect the engine state at up to 1 second apart and there is no way to correlate them. Many OBDII based systems log this way because of the limited speed of OBDII, but some of the manufacturers claim 30 samples or more per second.

Higher logging speeds

There are situations when higher logging speeds are needed. To analyze engine data on a crank degree basis at a resolution of 1 crank degree, requires measuring at 72000 times per second at 6000 RPM (6000 * 360 degrees * 2 [Nyquist] / 60). The applications for this are very specialized. An example is to analyze the point (in crank degrees) where flywheel acceleration is fastest. With the availability of fast and cheap microprocessors today this data can be analyzed on the fly and then the results logged (for example as max. acceleration point) at a much lower speed of 10-15 samples per second.

Another application for higher logging speeds is suspension analysis. There typically the shock velocity needs to be known under various conditions. Measuring rates of 1000-2000 times/second are required to calculate shock velocity and travel amplitude. But again, this data can be processed on the fly and then get logged at lower speeds by modern microprocessors.
2.1.3 Logging resolution

Logging most channels involves interpreting voltages. Typically for most of today’s sensors the voltage range is 0-5V. When a data logger reads these voltages they are converted into a number that is represented digitally. Converting the voltage to that number is the task of an analog-to-digital converter (abbreviated A/D or ADC). The highest number a A/D can represent conforms to the max. Voltage it can read and also determines the finest resolution it can read. The number of ‘bits’ of the ADC specifies that highest number. For example for an 8 bit A/D the highest number is 255 (2 to the power of 8 minus 1). It could resolve the input voltage into 5/256 Volts. For a 10 bit A/D the highest number is 1023 and the resolution is 5/1024 Volts. So the resolution for any sensor is:

\[ \text{Range} / (2 \text{ to the power of [number_of_bits]} ) \quad \text{or} \quad \text{Range} / 2^N , \]

Where N is the number of bits of the ADC.

Most MTS devices that read external voltages or internal sensors use 10 bit resolution A/D’s. The exception is the AFR/Lambda data. Even though the Lambda range goes from 0.5 to infinite, it is limited for logging purposes to 0.5 to 1.523 Lambda.

This is a 10 bit range with a resolution of 0.001 Lambda.

The LMA-3 internally digitizes with a 16 bit ADC. It then uses the extra resolution to filter out noise and finally reduce the resulting resolution to 10 bit for the MTS data stream.

⚠️ LogWorks always stores all channel data in the 10 bit raw format as digitized. How the numbers are interpreted for the user display depends on the user settable channel configuration. But the raw stored 10 bit numbers will not get changed when the interpretation changes.
2.2 Sensors and the Modular Tuning System

The Innovate modular tuning system (MTS) consists of various devices to measure, digitize and record various engine parameters. Typically these parameters are sensed by different sensors built either into the engine itself or into MTS components. These sensors measure for example temperatures, pressures, air-flow, air-fuel ratio and so on. Sensors convert the measured quantity into an electrical signal, typically a voltage between 0 and 5V, which can be logged or displayed by the MTS components. The sensors can be categorized generally into four different groups, depending on the output they produce:

a. **Voltage output sensors with external supply**
   These sensors have mostly 3 pins. One for the supply voltage (typically 5V), one for the output signal, and one ground. Sometimes the ground pin is omitted and the sensor is grounded through its metallic body to the engine. Typical examples are Throttle Position sensors (TPS), Manifold Absolute Pressure sensors (MAP), and Mass Air Flow Sensors (MAF). The output voltage has a typical range of 0..5V and varies for most sensors linearly with the measured quantity.

b. **Voltage generating sensors**
   These sensors generate a (small) voltage more or less proportional to the measured quantity. Typical examples are Thermocouples and (Narrow-Band) O2 sensors. Thermocouples output a very small voltage (in the microvolt range) that requires a special amplifier to make the signal readable and loggable. The LMA-3 Auxbox has such an amplifier built in. Narrow-Band O2 sensors output a voltage in the milliVolt range (up to 1000mV). Their voltage output has a jump from low (~100mV) to high (700mV to 1000mV) when the AFR of the exhaust gas changes from lean of stoichiometric to rich of stoichiometric. They act more like switches than actual sensors. Basically they can indicate lean, rich and stoichiometric.

c. **Resistive sensors**
   These sensors change their electrical resistance with the measured quantity. Very often the relationship between resistance change and the measured parameter is non-linear. Typical examples are Intake Air Temperature Sensors (IAT), coolant temperature sensors (CT) and some oil-pressure/fuel pressure sensors. Typically these sensors have 2 pins. One is ground, the other is connected to a load resistor. Often the ground pin is omitted and the sensor is grounded through its body to the engine. The other end of the load resistor is connected to a voltage supply (typically 5V). The purpose of the load resistor is to form a voltage divider with the sensor. At the connection between load resistor and sensor a voltage is formed that is dependent on the resistance change of the sensor according to this formula:

\[ V_{out} = V_{supply} \times \frac{R_s}{R_s + R_L} \]

Were \( V_{out} \) is the output voltage, \( V_{supply} \) is the supply voltage, \( R_s \) is the sensor resistance and \( R_L \) is the load resistor. For maximum sensitivity, \( R_L \) is typically chosen to be equal to \( R_s \) at the typical operating point.

A sensor that falls between resistive sensors and voltage output sensors with external supply is the throttle position sensor. Although it is a resistor with a movable tap, it behaves looks and interfaces exactly like a voltage output sensors with external supply.

d. **Frequency sensors**
   These sensors output a signal that varies in frequency (oscillating voltage) with the measured quantity. Examples are some MAF sensors, the tach signal that measures engine RPMs and the vehicle speed signal generated by drive-shaft or wheel sensors. The LMA-3 (Auxbox) has the capability to convert these frequencies into a digital or analog signal that can be interpreted and logged.
The MTS components convert the sensor data to a digital number between 0 and 1023 or a total of 1024 steps incl. 0. This is equivalent of a 10 bit resolution ($2^{10} = 1024$). The resulting resolution for a 0..5V signal is therefore about 4.9 mV. Any signal variations smaller than that cannot be resolved.

LogWorks has capabilities to convert the logged number back to the original quantity, provided the characteristics of the original sensors are known. This means that LogWorks needs to know how to convert the voltage output of the original sensor to the measured quantity equivalent.

The Air-Fuel-Ratio signal of the MTS components is not digitized from an external analog voltage. Instead it is internally calculated. For logging purposes this signal is internally always stored as Lambda with a resolution of 10 bits (1024 steps). To create the Air-Fuel-Ratio, the Lambda value is multiplied with the stoichiometric ratio for the given fuel (like 14.7 for gasoline) by the LogWorks software.

The data log range for Lambda is 0.5 to 1.523, equivalent to 1024 steps with a resolution of 0.001 Lambda (for gasoline this is equivalent to a 0.0147 AFR with a range of 7.4 to 22.4 AFR). This range is more than sufficient for spark ignited internal combustion engines. AFR/Lambda ranges outside of the logging range are pegged at the minimum or maximum point respectively.

See the manual for the MTS device you are using for details on how to connect various sensors.

### 2.3 Sensor Hookup

Most sensors requires a ground connection. The voltage output of the sensor is referenced to that ground. If the device measuring the sensor is connected to a different ground, the voltage difference between the grounds can shift the sensor output voltage relative to the measuring device. Some measuring devices, like the LMA-3, have differential inputs to compensate for that offset. The negative side of a differential input is NOT a ground. It is intended to be connected to the same ground as the sensor. A measuring device with a differential input measures the difference between its own ground and the sensor’s ground on the negative input and subtracts the difference from the measured voltage on the positive input to compensate for the ground offsets. The hookup from a differential input requires two wires. One for the signal itself and one for the ground reference. The ground reference input (typically named CHx-) goes to the grounding point of the sensor.

Ground offsets are especially problematic for resistive and voltage output sensors. They are not so important for frequency or duty cycle based sensors. For a measuring device with common ground, like the LMA-2, it is best to ground all sensors at the same point where the measuring device itself is grounded.

Ground offsets can also affect frequency or duty cycle based sensors. Typically when measuring a frequency, the signal is measured as ‘high’ or ‘low’ depending on the measurement device’s high-low threshold. In the LMA-2 or LMA-3 the threshold is 1V for the LMA-2 or 2.5V for the LMA-3. Ground offsets of 1V or 2.5V will not allow the device to measure correctly.

Another problem can be ‘ground bounce’. If the signal generating device (for example an ignition system) creates very high current pulses, it’s ground can momentarily ‘jump’ over the threshold of the measuring device because of the high current. These ‘ground-bounce’ pulses are measured as false frequencies and can interfere with the measurement.

Another problem in sensor hookup is called ‘induced noise’. In an engine compartment very high current pulses are routed many different places. These current pulses can come from the
injectors, ignition system or alternator. Any (changing) current flowing through a conductor creates a changing magnetic field. A changing magnetic field intersecting another conductor (for example the sensor wires) will create a voltage along that conductor. This voltage is added as noise to the sensor signal. This is how an antenna for radio signals works as well.

By twisting the sensor output and sensor ground wire together, that induced noise can be minimized. Each twist creates a wire loop acting as small antenna to pick up the induced noise. BUT, the noise induced in each loop changes polarity from loop to loop. This way each twist-loop cancels out the noise from the previous loop. The tighter the twist, the more cancellation can be achieved.
2.4 The Innovate Log-Chain concept

LogWorks 3.0 has the capability to log, display and analyze up to 96 engine parameters. Of those 64 can be regular channels with a variable and programmable range. 32 are reserved for “Bit Channels”, that can indicate only an on-off condition. Most MTS components read between 1 and 6 engine parameters. To interface a multitude of MTS components to LogWorks with a single connection, the Innovate LogChain concept was introduced.

Each of the MTS components has two serial ports (except the LM-1, which has only one). One serial port is designated as IN-port, the other as OUT port. The OUT-port of one device is connected to the IN-port of the next device and so on. This way devices can be ‘daisy-chained’ to build a log-chain for up to 32 channels total. The OUT-port of the last device is connected to the computer for logging or downloading of logged data.

The following diagram shows how to connect multiple MTS devices to form a log-chain. The example chain consists of a LM-1/LMA-2, a LC-1, a LMA-3 and 2 XD-16’s or XD-1’s. In this case the chain has 12 channels (6 from LM-1, 1 from LC-1 and 5 from LMA-3).

Devices attached to the LM-1’s analog input count as being part of the LM-1’s 6 channels. They don’t count extra. XD-1’s do not contribute any channels, so you can add as many as needed.

Another Example Log Chain (7 channels with 2 AFR channels):

The device that’s first in the chain is special. It determines the logging sample rate. The first device in the chain sends a data packet containing its channel data (a sample) to the next device (downstream, left to right in the diagram) every 81.92 milliseconds. The next device appends its data to that packet and hands that packet to the next device downstream and so on. At each device the packet grows in length. The devices in the chain synchronize their sampling of the engine parameters to the packets, so that all the channels in a packet together represent the same instance in time. At the downstream end of the log chain (OUT-port of the last device) a computer or external logger can be connected to store or display the stream data. The XD-1 display is such a device.

This also means that the complete channel data set is ONLY available at the end of the log-chain. A datalogger capable of recording the log-chain data-stream therefore MUST be placed at the end of the log-chain. This includes lap-top computers or other loggers.
Commands for individual devices are sent ‘upstream’. A device (incl. a computer or an XD-1) can send commands to the devices upstream of itself, but not downstream. Commands can include start-stop recording, calibration/configuration commands and so on. Only the device directly upstream of the command originator of course will receive the command. This device then decides, depending on the command, whether to execute the command and whether to pass it on. An example of a case where the command is executed but not passed on is the start-stop record command. The first upstream device capable of logging internally will execute the command, but not pass it on.

As said before, the first device is special because it is the synchronization source for the entire chain. By plugging its IN-port with the supplied terminator connector, a device can detect that requirement when it powers up. The terminator connector just connects the transmit and receive line of the IN-port together. Each device sends a special command out on it’s IN port when it powers up. This command is ignored and not passed on by any device if received on it’s OUT port. If the sending device immediately receives that command on its IN-port again, because the terminator is plugged in, it assumes it is the first and special device in the chain. The LM-1, having only one serial port, is ALWAYS a special device and MUST be connected to the beginning of the chain.

2.5 LogWorks Channels

A channel is the data from a single sensor, like AFR or RPM. Channels are the basic data items that LogWorks processes. Therefore their understanding is crucial to the use of LogWorks.

LogWorks 3 uses two basic channel types.

1. Value channels
2. Bit channels

2.5.1 Value channels

Value channels have a range and a unit. For example RPM from 0 to 10230 RPM, Mixture data from 7.35 to 22.4 AFR, Throttle position from 0 to 100 %.

In the first case the unit is RPM, range 0..10230.
In the second case the unit is AFR, range is 7.35 to 22.4
In the third case the unit is %, range is 0..100.

In either case a MTS device reads the measurement and translates the result into a raw data number. In most cases the raw data measured is a Voltage in the range 0 Volt to 5 Volt that is sent to LogWorks. The Channel Configuration database of LogWorks then tells LogWorks how to translate the raw data into the appropriate units and range. For convenience, and because it is the most common case, the raw data is always treated as if it were digitized from a sensor with a 0 to 5Volt output.
See chapter 4 for details about channel configuration.

Value channels can be created a few different ways:

a. Directly measured with an MTS device.
b. Created by a “virtual” device plug-in that connects to LogWorks.
c. Created mathematically from other channels either with the LogWorks math engine or by a program plug-in.
The Range in the channel configuration ALWAYS has to match the range to which the original quantity was digitized. For example most MTS devices that measure RPM output the raw RPM data to a default Range of 0V equivalent to 0 RPM and 5V to 10230 RPM.

Configuring a channel to a different range than it was digitized to, causes a wrong translation of the indicated data in LogWorks.

2.5.2 Bit channels

Bit channels are very simple channels. They can only indicate two states: On and Off, or 1 and 0 or High and Low. They are used to indicate engine states like:

- Closed Loop or Open Loop.
- Acceleration enrichment on or off and so on.

Bit channels do not have a range or unit. They only have a name. Their state is immediately apparent and therefore they don’t need any more definition like value channels. Like Value channels they can also be created different ways:

a. Directly measured with an MTS device.
b. Created by a “virtual” device that connects to LogWorks.
c. Created mathematically from other channels either with the LogWorks math engine or by a program plug-in.

2.5.3 Identifying devices and Channels

To easily identify which channel is representing which engine parameter, the channels must be given a name. Use short names to not use up a lot of screen real-estate.

USE ONLY NUMBERS AND LETTERS IN A CHANNEL NAME. THE ONLY SPECIAL CHARACTER ALLOWED IS THE UNDERLINE CHARACTER _ . A CHANNEL NAME MUST START WITH A LETTER.

LogWorks allows you to configure each channel. Part of the configuration is the name. Also the color in which the channel is displayed is programmable in LogWorks as well.

To further easily identify the channels each MTS device MUST be given a name. This name can be up to 8 characters long and is programmed into the device. Use the LM Programmer application to change the name of a device. This is especially important when multiple devices of the same type are used.

When LogWorks start up, it will identify the devices in the LogChain. If new devices have been added or devices removed, LogWorks will automatically change its channel configuration to reflect the new log-chain configuration. Channels associated with a device previously will stay associated with that device, even if the device has been moved to a different location in the chain, provided it has been given a unique name.
LogWorks will maintain the channel configuration for each device, IF THE DEVICE IS GIVEN A UNIQUE NAME WITH LM PROGRAMMER, even if the device has been moved to a different position in the LogChain. This is NOT true for display devices like the XD-16. The XD-16 is sensitive to the position of its programmed input in the LogChain. This means that if you moved for example an LMA-3 from the first position in the LogChain to the second position, and have the XD-16 programmed to display or use (hold or warning) an XD-16 channel, you need to reprogram the XD-16.
2.6 Logs and Sessions

Different from other data logging products, LogWorks organizes the acquired data in logs and sessions. A session is a contiguous data set. This means there is no interruption in the data stream and all data points are spaced equally in time (81.92ms apart). Each time you start logging, a new session is created and the session ends when the logging stream is stopped.

A log is a collection of sessions. In a typical qualifying race or tuning session multiple runs are made, and each run is data logged. LogWorks conveniently organizes these runs into a common log. The sessions in a log are numbered from 1 through x. Typically they are sequential in time, starting with the oldest session as session 1 and so on. Each log can be stored in a separate file on the computer. Each session can be renamed so it does reflect something more meaningful than just a numbered sequence.

In addition each log contains the information on how to convert the digitized numbers (see Logging engine data) into the original quantities. These so called channel settings apply to all sessions in a log.

LogWorks distinguishes three different kinds of logs:

a)  Real-time log

This is a log created by connecting a computer to the MTS log-chain and recording the real-time data stream from the MTS devices to the computer's hard drive. New sessions can be added at any time by starting to record the serial stream. Only one real-time log can be open at any time. The current real-time input settings apply to the real-time log.

b)  LM-1 log

This is a log created by downloading log data from the LM-1’s internal memory, but not yet stored in a file. Only one LM-1 log can be open at any time. The current real-time input settings apply to LM-1 log.

⚠️ The LM-1 has to be the first device in a log-chain. Therefore the only channels it can see are its own AFR channel and the 5 channels on its Aux input. The LM-1 can NOT record any other channels downstream in the log-chain.

c)  File logs

File logs are data files created by LogWorks when saving a real-time log or a LM-1 log. Up to 30 such logs can be opened by LogWorks concurrently. LogWorks stores logs in either of two file formats:

Log files (file extension .log)
Or
DIF files (file extension .dif)
The .log file format is native to LogWorks. It stores the original data in a very compact format and also stores additional information like measurement points, filter parameters and all input settings. This allows to change and manipulate the data later more conveniently than the DIF file format.

The DIF file format is used to allow importing the log data into spreadsheet program like Microsoft Excel.

The DIF format stores the data as manipulated by LogWorks and already converted into the real engine quantities. Because of that, information can be lost when reloading a DIF file for further manipulation.

The DIF format should only be used when the log data is to be processed by external software like Excel.

⚠️ **LogWorks 3.0 LOG files (file extension .log) are different from log files created by an earlier version of LogWorks. Although LogWorks 3.0 can read the earlier files, an earlier version of LogWorks can’t read the new file format fully.**

**LogWorks 3.0 LOG files can be read by LogWorks 2.x, but if more than 32 channels, or bit channels, are stored, those won’t be visible in LogWorks 2.x.**

### 2.7 LogWorks Files and Folders

LogWorks uses the following files and Folders. These are installed in the same directory or folder where the LogWorks program file (LogWorks.exe) is installed.

#### 2.7.1 Files used by LogWorks 3 in the main Folder

- **LogWorks.exe** (the main LogWorks Program)
- **Mts.dll** (the MTS serial protocol manager – includes plug-ins for LM-1, LC-1, and LMA-2)
- **Conversions.txt** (text file containing formulas for unit conversions. See section x)
- **MathlibSI.txt** (text file containing mathematical formulas in international units [MKS system] for channel calculations)
- **MathlibUS.txt** (text file containing mathematical formulas in US units [pounds, degF and so on] for channel calculations)
- **ChartMathlib.txt** (text file containing mathematical formulas for 3D-chart calculations)
- **Searchlib.txt** (text file containing formulas for frequently used searches)

#### 2.7.2 LM1 Log Files Folder

This Folder is the default location for Log Files. Regular Log Files have the file extension .log
2.7.3 LWSettings Folder

This folder is the default location for LogWorks Settings like Input Descriptions, Profiles and Skins (see later chapters) are stored in this directory.

Input description files (extension .inp)

These contain sets of channel descriptions. Each channel description contains data about a channel like name, unit, how digitized voltages are translated to units, channel trace color, possible lookup table and channel type and source (from which MTS device). Input description files capture the current channel settings of all channels.

Skin Files (extension .skn)

A skin file describes the “look and feel” of LogWorks gauges like colors used, background picture, bezel style and numeric digit style.

File Currentskin (no file extension)

This is a skin file that saves what the user has selected as current skin. It is saved and stored when exiting LogWorks.

File DashTemplates (no file extension)

This file contains a database of dash templates. A dash template contains the number of gauges on the LogWorks Dash, their location, size and type, and what channels are assigned to each gauge. Up to 16 named templates can be stored in the DashTemplates file.

File LWTemplates (no file extension)

This files contains templates for the main realtime trace window, the realtime X-Y Plots and Realtime charts. These templates are stored by default into a log file when a new realtime log is saved the first time.
3 Starting up LogWorks

Connect OUT port of the last device in the Log-Chain to a free serial port on your computer and start the LogWorks program. If an LM-1 is used, the LM-1 can either be currently operating in the car or can be connected (running from its internal battery) to the computer. Real-time logging can of course only be done when running the Log-Chain (can be as small as just an LM-1) in the car.

⚠️ For Real time display, logging or download from an LM-1 make sure no other program (including LM Programmer or LM-1 Manager) is using the selected serial port.

LogWorks can handle channels coming from a MTS Log Chains as well as so called virtual channels that are created by non MTS devices. Plug-ins for almost any device that supplies engine data can be created. This includes OBDII data readers, aftermarket ECUs and piggybacks, dynos or other devices. One restriction is that at least one MTS device has to be connected to the computer for real time logging.

For log viewing, LogWorks is also automatically started when double-clicking on a .log file.
3.1 The LogWorks 3 Dashboard

Note: The actual look of the window background and gauges depends on the selected skin.

This window is resizable by grabbing on the lower edge of the window. All gauges are grayed out until:

a) LogWorks is connected to the Log Chain  
b) A valid serial data stream is detected on the serial port  
c) The appropriate input is enabled.

When this happens the window might look like this with the gauges active.
3.1.1 Changing the preferences for units

This menu allows you to set your preferences for unit calculations and for displaying channels. A lot of calculations are different when US units vs. international units are used. To make it easier to find the correct calculations, the math libraries are divided, so that the number of duplicate entries is minimized.
4 Channel Setup and Configuration

Channel configurations from the LogWorks Main Dashboard will be stored in the computers registry and will be applied to real time logs and to downloaded logs from LM-1 and DL-32 automatically.
Channel configuration changes done in the already downloaded log from the Log Window apply only to that log.

See chapter 2.5 for details about channels.

A LogWorks channel needs to be configured. The Configuration is very important for LogWorks because it tells LogWorks how to:

   a. Translate raw digitized data into the appropriate measurement in units, scaling and range.
   b. In what color the trace should be shown in the LogWorks menu.
   c. What the channels should be named.

The “Channels” Menu of the main window allows configuring logged or displayed channels.

In the Channel Menu, go either to

Channels→Configuration Wizard...

Or

Click on the tool in the toolbar.

Either way brings up the Channel Configuration Wizard Dialog Box.
The main page of this dialog box shows the current Log-Chain as detected by LogWorks 3. Click on the device whose channels you want to configure. In the above example it is a LMA-3 named, coincidentally, also LMA-3. Additional Tabs for the channels from that device are then created. Click on the tab of the channels you want to configure.

⚠️ If you download from an LM-1 or DL-32, or if you connect to a MTS Log-Chain the first time, LogWorks will automatically detect devices which have not yet had a channel configuration assigned to them. It then forces you to configure those channels.

If you find that annoying, enable the “Don’t show this wizard for future downloads” checkbox.

When clicking on a channel tab the following dialog box appears (for value channels):

⚠️ The same dialog box will appear when you directly configure a channel with the menu selection: Channels->Configure Channel->Channel name, or right-click on a gauge assigned to a channel.
The dialog box contains multiple fields. For bit channels, only field 1 and possibly field 3 and 4 are shown.

Field 1.
In field one you can specify a name for the input for easy identification. Use a unique name.

⚠️ Only letters, numbers and the underline character _ are allowed in an input name. A channel name may not start with a number.

If multiple channels measure similar data, like multiple EGT or Lambda/AFR channels, name them with a number at the end like:

AFR_CYL1, AFR_CYL2 and so on. This makes it easier for LogWorks to create channel group names.
Field 2.
Click on this field to change the trace color for this channel. See chapter 4.3 on details of manipulating channel color.

Field 3.
This indicates the input mode selected for this input of the selected device, dependent on the device. LogWorks interrogates all devices connected to the serial LogChain during connection and downloads their settings. If the settings have changed since the last time LogWorks started, LogWorks will change the current input to the current settings of the input, using defaults for the unit and range. If a device is connected to the Aux-In port of the LM-1, it can’t be interrogated by LogWorks. In this case you have to manually select the function and, if necessary, fill out the fields for range and unit. See the manual for the appropriate device for details.

Field 4.
This field shows the name, type and icon of the device where this input is from. If a device allows the connection of optional accessories, the accessory selected is also shown.

Field 5.
Either type in the unit for the channel here or select a unit from the drop-down list. The drop-down list shows all units that are preprogrammed into LogWorks. For details about using units and unit conversions see chapter xxx.

Units typically belong to a unit family. A unit family consists of different units for the same measured quantity. For example you can measure pressure in PSI, inHg, kPascal and so on. Conversion formulas describe how to convert between different units of the same family. In the drop-down list the units belonging to the same family as the current unit are shown in bold face. When converting between absolute pressure and gauge pressure LogWorks will ask you to enter the current atmospheric air pressure:

![Atmospheric Pressure](Atmospheric_Pressure.png)

You can enter this in either in inches of mercury (inHg) or millibar. LogWorks decides from the number entered which unit is used. This is asked only once after LogWorks has started and will not be asked again if that conversion is executed again. For details see chapter xxx.

Field 6, 7 and 8
Specify two voltages (0 and 5V in the above example) in field 7 and the equivalent measurement quantity (0 and 10230 RPM respectively in the example). If voltages different than 0 and 5V are specified, the range will be automatically expanded to 0..5V if the push button “Expand to 0..5V” in Field 5 is selected, even if the sensor is not capable to produce 0..5V (the measured signal will stay within the range the sensor produces).
If the “Limit to programmed range” push button is selected, the input is limited to the programmed range in field 3. Input values outside the range will be clipped to the entered range. To easily enter the correct voltage values when LogWorks is connected realtime to a Logchain, you can also right-click on one of the voltage fields.
TPS Example:
To calibrate a TPS sensor, connect the sensor to for example an LMA-2 or LMA-3, switch the ignition on but don’t start the car. Enter % as the unit and enter 0 in the upper box of field 3. Then right-click on the upper box of field 4. A menu will show up that allows you to paste in the current voltage of the TPS sensor into the upper box of field 4.
Next enter 100 in the lower box of field 3, depress the gas pedal fully and right-click in the lower box of field 4. Paste in the full throttle voltage.

Field 6.
Clicking on the “Invert Scale” exchanges the upper and lower boxes of field 3. This is useful for example for duty-cycle measurement. Normally the LMA-3 will measure positive duty cycle. This means that 100% duty cycle happens when the input is at full voltage and 0% when the input is a 0Volt. A typical fuel injector and also ignition points show full voltage when off and 0V when on. This is a negative duty cycle. By inverting the scale you can measure this duty cycle correctly where 0V means 100% and full voltage means 0%.

Field 9.
Inverts the scale, so the 0V equivalent becomes equivalent to 5V and the 5V equivalent becomes 0V.

Field 10.
Adds or deletes custom lookup tables. See chapter 4.1 for details

Field 11.
Clicking on this button brings up a little calculator box.

<table>
<thead>
<tr>
<th>Conversion Calculator</th>
</tr>
</thead>
<tbody>
<tr>
<td>RPM</td>
</tr>
<tr>
<td>10230</td>
</tr>
</tbody>
</table>

Type in the unit or voltage. The equivalent unit or voltage will be calculated

This is a convenience to quickly calculate the voltage equivalents (or unit equivalents) for the current channel configuration.
4.1 Custom Input Lookup Tables

Many sensors used in cars have a non-linear response curve. This means that their output voltage does not follow the measured quantity linearly but with some sensor dependent curve. LogWorks allows you to enter points of that sensor curve (as many as 1024, the more, the better) to convert the sensor output voltage back into the measured quantity directly. LogWorks interpolates the sensor measurements between entered points.

Press the Load/Edit Table button in Field 10 of the Channel Configuration Dialog, and you will be presented with the following dialog box:

Double click on any field in the table to modify it. Click on a field to select it. To delete an entry, select it and hit the delete key.

If you make changes by editing, click anywhere in the table to make the changes permanent.

You can import a new lookup table from a text file (extension .txt) or a DIF file created by a spreadsheet program (extension .dif). A text table must have two columns, separated by spaces or tabs.

The first line of the left column contains the unit of the measured quantity (RPM in our example). The right column, first line must contain the word “Volt”.

In the succeeding lines contain the individual equivalents of the lookup table. Left column contains the measured quantity and the right the equivalent voltage.

⚠️ The slider on the left of the window shifts the entire table voltages up or down to compensate for ground differences between the MTS device ground and the

- 32 - LogWorks3_Manual_1.01.doc
measurement sensor. This should NOT be used with devices with differential inputs like LMA-3, SSI-4 and/or DL-32. They automatically compensate for ground differences when connecting the CHx- input to the sensor’s ground.

The following is an example of an input lookup table:

<table>
<thead>
<tr>
<th>PSI</th>
<th>Volt</th>
</tr>
</thead>
<tbody>
<tr>
<td>-14.7</td>
<td>0.1</td>
</tr>
<tr>
<td>-10.0</td>
<td>1.2</td>
</tr>
<tr>
<td>0</td>
<td>2.1</td>
</tr>
<tr>
<td>5</td>
<td>2.8</td>
</tr>
<tr>
<td>15</td>
<td>4</td>
</tr>
<tr>
<td>29.4</td>
<td>4.9</td>
</tr>
</tbody>
</table>

A DIF file must be organized similarly. The top left entry in the spreadsheet (field A1) must contain the measured unit. The second entry (field B1) MUST contain the word “Volt”. The rest of the ‘A’ column contains the measured quantity equivalents and the rest of the ‘B’ column contains the equivalent voltages.

When loading the table LogWorks sorts it in ascending order by voltage. LogWorks then creates a custom lookup table for all 1024 possible input values by interpolating between table points using what’s called cubic splines (Not the right place here to explain what they are). The table must be monotone rising or falling. If the difference between the second quantity and the first quantity is positive, the quantities must be always rising (third bigger than second and so on). If the difference is negative, the quantities must be always falling (third smaller than second and so on). If this were not the case, the same voltage could mean different measured quantities.

Example of monotone lookup table (x in PSI, y in Volt):

```
-20 -20 0 10 20 30 40
-10 0 1 2 3 4 5
0 1 2 3 4 5 6
```
An example of a wrong table:

<table>
<thead>
<tr>
<th>Voltage (V)</th>
<th>PSI</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0 PSI</td>
</tr>
<tr>
<td>0.5</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td></td>
</tr>
<tr>
<td>1.5</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
</tr>
<tr>
<td>2.5</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>15 PSI</td>
</tr>
</tbody>
</table>

Note that 2.1 V could either mean 0 PSI or 15 PSI.

\[\text{Different than the custom setting in Field 6. and 7. of the Channel Configuration dialog box, the lookup table will NOT be automatically expanded to 0..5V. Instead the resulting log is clipped to the minimum and maximum of the table entries.}\]

\[\text{If this dialog box was started from the LogWorks main window, double-clicking on one of the voltage fields, then right clicking on it will show a menu that allows you to paste the current input voltage of this input.}\]

When Clicking the Thermistor Temp Sensor button in this Dialog Box, it will show the Thermistor calculator.

### 4.2 Thermistor Temp Sensor Configuration

Most IAT or CT sensors are actually NTC thermistors. So are many oil-temperature sensors. NTC stands for negative temperature coefficient. These sensors are resistance type sensors and their resistance changes such that it lowers with higher temperature. The resistance curve over temperature is not linear. Although there are many published resistance curves for commonly available IAT or CT sensors, these tables typically show only the nominal values. Actual production sensors can vary by as much as 20% from the nominal values. For many applications, like turbo or intercooler efficiency calculations, multiple sensors are needed to measure pre- and post intercooler or compressor temperatures. The wide tolerance of production sensors makes it necessary to custom calibrate them to get reliable accuracy. If correctly calibrated, any cheap thermistor is just as accurate as a lab-grade temperature sensor.

The thermistor calculator can produce a custom input lookup table for LogWorks. For that it needs the resistance of the sensor at three different temperatures. The temperatures MUST differ from each other by at least 25 degC or 45 degF.
Of the three measurement points, the easiest to get is the middle point. Just leave the sensor in a warm room (Room Temperature at or above 25 degC or 77 degF) for at least an hour. Measure the resistance of the sensor with a digital multimeter and write it down. Also record the temperature with a good thermometer.

Two other easy temperature standards available to everybody are the freezing point of water (0 degC or -32 degF) and the boiling point of water (100 degC or 212 degF). Water does not usually hurt NTC resistor sensors. Just make sure they are thoroughly dried out after the measurement. To get the 0 degC resistance, fill a small plastic container with a mixture of ice-cubes and water. Connect a multimeter to measure the sensor resistance and put the sensor in the ice water. Wait until the resistance has stabilized, indicating the sensor is at the same temperature (0 degC) as the water.

Next put the sensor in a pot of boiling water and repeat the measurement, again waiting for the temperature and resistance to stabilize.

### 4.2.1 Thermistor circuit

Most ECU’s and also the Innovate MTS products do not measure resistance directly, but measure a voltage. To convert the resistance of the sensor into a voltage requires a 5V power supply and a load resistor.

The typical circuit for this looks like one of the following schematics:

A. Sensor Grounded

B. Sensor at 5V

In case A, the sensor is grounded on one side. This is the most common case where the sensor body is in physical contact to the engine, and is grounded through its body. Very often these sensors have only one pin.

To find out, which circuit your ECU uses, measure the voltage between each of the two sensor pins (if it has two) and ground. If one voltage is zero and the other is some voltage between 2 and 5V when the sensor is cold, you have circuit A. If one voltage is 5V while the other is lower, you have circuit B.

To get the voltage curve, you also need to know the value of the load resistor. You can’t measure it directly with the multimeter though, because it would interfere with the ECU and can possibly damage it. The method to use goes as follows:
Schematic case A.

1. Disconnect the sensor from the ECU and measure the voltage between ground and the sensor pin at the ECU (measurement point MP).
2. Switch the multimeter to current measurement and measure the current in mA between MP and ground.

Schematic case B.

1. Disconnect the sensor from the ECU and measure the voltage between the two sensor connection pins of the ECU.
2. Switch the multimeter to current measurement and measure the current in mA between the two sensor connection pins of the ECU.

The load resistance (in kOhm) is the measured voltage divided by the measured current in mA.

If you use a MTS device with a 0..5V input you have to provide your own load resistor. In case of the LMA-2 you also have to provide a 5V supply. Connect the load resistor and sensor as follows:

If you are using a MTS device to tap into an existing IAT sensor hooked up to an ECU, omit the load resistor in the schematic above, but instead rely on the load resistor built into the ECU, measured as described earlier.

4.2.2 Configuring a Thermistor

The Thermistor calculator creates a thermistor curve by solving the extended thermistor formula:

\[ \ln(R) = B_1 + B_2/T + B_3/T^3 \]

Where \( R \) is in Ohms and \( T \) in Kelvin.
Specify if you want to enter the temperatures in Fahrenheit or Celsius. Also, specify if the resistances used are in kΩ or Ω and if circuit A (sensor grounded) or B (sensor at 5V) is used.

The calculations assume the circuit (A or B) is run from 5V.

Enter the desired measurement temperature range. The range must be at least 50 degC or 90 degF.

Also enter the three measurement points from the calibration procedure as described above.

If you are making your own circuit, you can have Thermistorcalc calculate the optimum load resistor. The temperature where this circuit has its maximum sensitivity is when the resistance of the sensor and the load resistor are equal. Thermistorcalc calculates the sensor resistance at the mid-point of the specified range and outputs the closest standard resistor value to that.

Do not make the load resistor smaller than about 1/5th of the thermistor resistance at room temperature.

Once all fields are filled out, click on the ‘Create Table’ button. Thermistorcalc will generate the correct lookup.
4.3 Changing Channel Trace Colors

Each value channel has assigned to it a specific color. This makes it easy to identify channel traces in a log. You can change trace colors from the Main Dash Window either with:

Channels->Change Trace Colors...

or by clicking in Field 2 of the Channel Configuration dialog box. In either case the following dialog box will appear.

On the left side of the dialog box, select the channel whose color needs to be changed. Click anywhere on the color circle to change the hue or saturation of the color. Saturation is how ‘intense’ the color is. Gray scale colors have a saturation of zero and are located in the center of the circle. The distance from the center is a measure of the saturation. The slider on the right of the window determines the brightness of the color (in % of the max brightness achievable for the selected hue and saturation).

4.4 Storing and loading channel configurations

LogWorks automatically stores the last channel configurations in the computers registry. It actually stores up to 100 of the last used configurations of all channels and retrieves the one best fit to the current MTS chain when LogWorks connects.

To store the current channel configuration (of all channels) manually, use the Main Dashboard menu:

Channels-->Save Input Description...
This allows you to store the current input description in a file in the LW Settings Folder. By default input description files have the file extension .inp. You can load a stored input description either from a .inp file or extract the channel description from an already stored .log file with the Main Dashboard menu item:

Channels→Import Input Description...
5  LogWorks Gauges

LogWorks uses gauges similar to what you find on a car's dash to indicate the current value and state of a channel.
Gauges can be added and removed any time. Multiple gauges can be assigned to the same channel and some gauges can also display multiple channels.
Any aspect of the gauges like colors, size, type and position is user selectable.

To add a gauge, select in the main dash menu:

Gauges->Add new Gauge,

Or in the Main Dash Window toolbar, click

5.1  Anatomy of a LogWorks gauge

A gauge in LogWorks has:

1. A face.
2. A scale. The scale range is the range of the displayed channel, divided into convenient divisions.
3. A needle
4. Unit and multiplier. The multiplier, like x 1000 in the unit part allows the scale to use smaller numbers. The unit text is omitted if the unit and the channel name are the same.
5. A channel name.
6. A numeric display. This shows the current channel value numerically.
7. A redline area (optional). This is a warning area.
8. A bezel. This is also optional and for optical purposes only.
9. Min-Max indicators. These show the min/max needle position since the gauge was last reset.

5.2 LogWorks gauge types

LogWorks can display seven different gauge types: Round, vertical bar, horizontal bar, multi-channel, vector, numeric and indicator light.

Round gauge (default)  Vertical bar  Horizontal bar

Multi-Channel  Vector  Numeric  Indicator Light

5.2.1 Round, Vertical Bar, Horizontal Bar, Multi and Numeric gauges

The Round, Vertical bar, Horizontal bar and Numeric gauges display just a single channel. A multi-channel gauge can display any number of channels that have the same unit. The scale range of a multi-channel gauge is determined by the lowest range point of all channels to the largest range point of all channels assigned to the gauge. If the channel displayed has a range that goes from negative to positive values (as shown in the vertical bar), a bar gauge can be programmed so it’s bar indicator always starts at the zero point.
5.2.2 Vector gauge

A Vector gauge is used to show two channels with the same unit that together form a “vector”. A vector is a quantity that has both, a magnitude and direction. The prime example is side-force and acceleration/braking. The combined force is indicated by the length of the “needle” in the gauge, the direction of the force by the direction of the needle. For example if acceleration/braking is assigned to the vertical axis and side force to the horizontal axis, the needle shows the force and direction acting on the tires. The numerical display of the gauge (upper right corner) shows the value of the combined force.

Min/Max hold does not make direct sense for a vector gauge. Instead the vector gauge records the max length and direction of the needle with a resolution of 2 degrees and indicates that.

A redline area also does not make sense. Instead for the vector gauge for acceleration and side force the limits in acceleration, braking, side force left and right are used to create a limit ellipsoid. The ellipsoid consists of four quarter ellipses for the four quadrants of the gauge. The first one (from top clockwise) is determined by the acceleration limit and right side force, the second by right side force holding limit and braking limit, the third by braking limit and left side force holding limit and the last by left side force limit and acceleration limit. The total traction force available from the tires described in an ellipsoid on a vector graph is often called “The Circle of Traction”. If the car is being driven to the traction limit and the needle touches the ellipsoid, theoretically the car looses traction. The Vector gauge provides an analysis tool of how efficiently and thoroughly the available traction is being utilized, how close the driver is getting to the limit of the tires.

5.2.3 Indicator Light

The Indicator light is the simplest gauge. It is usually used to display the state of Bit channels. It can also be used to create a warning light if a certain value in a value channels is exceeded. The “Light” color of the indicator is programmable. An Indicator light can be made to simply light up or to “blink” if on.

5.3 Selecting, adding, deleting and editing gauges.

5.3.1 Selecting a gauge

When clicking on a gauge the gauge becomes highlighted as in this:
You can drag the gauge anywhere in the window. You can change its size by dragging one of the rectangular corner “handles” in the gauge outline.

To select multiple gauges, hold down the Ctrl key while selecting more gauges. The first gauge you clicked will be the anchor gauge with yellow handles. More on that later.

To de-select all gauges, click outside a gauge in the window.

Another way to select multiple gauges is to click outside a gauge and drag with the mouse. A rectangle will be drawn on the gauge background. When the mouse button is released, all gauges whose center is within the rectangle, will be selected.

5.3.2 Adding and editing gauges

To add a gauge, select in the main dash menu:

Gauges-->Add new Gauge

Or in the toolbar, click.

To change the gauge type, channel, redline area and so on of an existing gauge either:

Double-click on the gauge,

Or click on the gauge and select in the Dash Window Menu:

Gauges-->Edit gauge.

In either case the following dialog box will show:
The current gauge type is highlighted. Use the scroll bar to show more gauge types.

The channel drop-down shows the currently assigned channel.

In the Marks and Redline area you can select to either have no redline, just a single mark or the range of the redline area.

When using Multi-channel gauge as a gauge type the channel selection drop-down works differently from a normal drop-down. Selection of a first channel determines the channel type and only channels with the same unit will then be additionally selectable. Select all channels that you want to assign to the multi-channel gauge.

The dialog box will look differently if an indicator light is selected as gauge type:

The Marks and Redline area (if a value channel is selected), allows you to specify the condition under which the light will be on. You will also be able to change the light color.
5.4 **Skins and colors**

A Skin is a set of definitions how gauges are to appear. The appearance applies to all gauges in LogWorks, not only to the main dash. A skin contains:

a. Digit Style for the numeric display of the gauges  
b. Bezel Style  
c. Background image, color and usage  
d. Face Color  
e. Ring (Bezel) Color  
f. Scale/Name/unit color  
g. Inactive color for Scale/Name/Unit (used when the displayed channel is inactive)  
h. Needle Color  
i. Digit Color for the numeric display of the gauge  
j. Redline/Mark color  
k. Min Mark Color  
l. Max Mark Color

All those options can be selected under the Skins/Colors menu in the LogWorks Main Dash. When selecting any of the color menu items a color selection dialog box appears:

Click anywhere on the color circle to change the hue or saturation of the color. Saturation is how ‘intense’ the color is; hue is the color itself (red, yellow, green and so on). Grays have a saturation of zero and are located in the center of the circle. The distance from the center is a measure of the saturation. The slider on the right of the window determines the brightness of the color (in % of the max brightness achievable for the selected hue and saturation).
5.4.1 Backgrounds

A background is the image on which the gauges are drawn. It can be either a solid color (select with **Colors/Skins->Background->Solid Background color**), or an image (load with **Colors/Skins->Background->Use/Load Background Pattern…**)

You can load any *.bmp, *.jpg or *.jpeg file as background image. For many purposes it is advantageous to use “tileable” patterns as background image. A tileable pattern can be repeated horizontally and vertically. If the pattern is tileable, it does not show any seams between repeats of the image. This is often used to simulate natural materials like stone, leather or wood. Search on the internet for “Texture Library” to find many tileable patterns.

When using a tileable pattern indicate this to LogWorks with:

**Colors/Skins->Background->Tile Background Pattern**

Otherwise use:

**Colors/Skins->Background->Stretch-to-Fit Background**

⚠️ **Solid Backgrounds use the least processing power to draw, Stretch-to-Fit the most. The least processor intensive skins are the “LogWorks classic” and “Graphics” skins that came preloaded with LogWorks 3.**

This is especially true for gauge ring styles that texture map the background to the gauge ring like angled and rounded background style.

If the computer you are running is slower than 1 GigaHz it is better to use solid backgrounds.

5.4.2 Saving and Loading Skins

Skins are saved in files with the extension .skn, by default in the LW settings folder. When LogWorks exits, it also saves the current skin in a file named “Currentskin”. A number of pre-created skins are already installed in the LW settings folder.
5.5 Changing gauge sizes and position

Gauges can be easily repositioned by dragging a gauge.

5.5.1 Changing gauge size

To change the size of a gauge, select the gauge and drag one of the “handles” in the selection rectangle.

To change the sizes of multiple gauges at once to the same size, size one gauge to the size you want first. Then select additional gauges by clicking on them while holding the Ctrl key.

Then, in the Gauges Menu of the main dash, select either:

Gauges->Equalize Size by->Width or
Gauges->Equalize Size by->Height

5.5.2 Aligning gauges

To align multiple gauges at once, select one and then select the additional gauges by clicking on them while holding the Ctrl key.

Then use the alignment options in the Alignment menu:

Gauges->Align->...

To distribute gauges equally across or vertically in the window, select the gauges to be distributed as described above and select either:

Gauges->Distribute evenly->Across or
Gauges->Distribute evenly->Vertically

5.5.3 Changing gauge depth position relative to other gauges

Sometimes gauges are positioned to overlap. Which gauge is in front and which is in the back can be adjusted by:

a. Select the gauge
b. Use Gauges->Send To Back or
c. Gauges->Bring to Front
5.6 Resetting and displaying Min/Max Value of a gauge

5.6.1 Resetting Min/Max hold

The current Min-Max recording of all gauges can be reset with either:

**Gauges->Reset Min/Max**

Or with the tool in the Toolbar of the main Dash.

To reset the Min-Max of an individual gauge hold down the Ctrl key on your keyboard and click on the gauge with the right mouse button.

5.6.2 Displaying Min/Max Values

Move the mouse cursor over a gauge. After a short delay the current Min/Max hold value the gauge has stored will be shown.

5.7 Using multiple gauge sets

When recording many channels, for example with a large Log-Chain, it is often convenient to use multiple gauge sets for different applications. Otherwise the window can get too crowded with too many gauges. The Gauge Set Manager allows to store up to 16 different gauge sets.

A gauge set contains the size, position, type and channel assignment of all gauges on the dash.

To store the current gauge set use the gauge set Manager.

Select in the Main Dashboard:

**Gauges->Gauge Set Manager**...

The gauge set manager window will appear:
It shows the currently stored sets. Enter a new set or template name and click save. To rename a set, select it in the list and enter a new name. Then click Rename. To delete a set, select it in the list and click delete.

To select a gauge set, select in the Main Dashboard

Gauges->Select Gauge Set->gauge set

5.8 Full Screen Mode

LogWorks 3 can be very conveniently used as dash window display for an in-car computer. In that application it is often desirable to hide the Windows user interface features and JUST show the gauge window of the dashboard. LogWorks 3 has a provision for that.

To enable the full screen mode, select in the Main Dashboard menu:

Preferences->Go to full screen when maximized

If the Main Dashboard window is subsequently maximized, after 5 seconds of no mouse or keyboard activity, LogWorks will further maximize the gauge screen to cover the entire computer screen. Moving the mouse, or pressing a key, will cause LogWorks to revert back to normal maximized window mode.

Full maximization is prevented if a log is currently being recorded. Otherwise no access to the log window will be easily possible.
6 Using the LogWorks Main Dashboard

Aside from manipulating and displaying gauges and configuring channels the Main dashboard is used to:

a. Connect real time to the MTS Log Chain and virtual devices
b. Start new real time logs
c. Load existing Log Files
d. Download Logs from LM-1 or DL-32

6.1 Connecting to the MTS Log Chain

Connect OUT port of the last device in the Log-Chain to a free serial port on your computer and start the LogWorks program. If an LM-1 is used, the LM-1 can either be currently operating in the car or can be connected (running from its internal battery) to the computer. Real-time logging can of course only be done when running the Log-Chain (can be as small as just an LM-1) in the car.

6.2 Real time logging

⚠️ For Real time display, logging or download from an LM-1 make sure no other program (including LM Programmer or LM-1 Manager) is using the selected serial port.

Select in the Main Dashboard Menu:

File→Connect..

And select the correct COM port where you connected the MTS chain.

If you want LogWorks to automatically connect whenever it is launched, select also:

File→Autoconnect on Start

If LogWorks does not detect MTS data after a 10 second timeout period it will display an error message. However, while the error message is displayed, it will continue monitoring for MTS data. If it detects MTS data, it will remove the error message and continue normally. If this happens during logging, the current session will be terminated and a new one created.

To start a new log immediately, select in the Main Dashboard Menu:

File→New Realtime Log

Or, in the Toolbar, click on the ⬇️ Tool.

A new Log Window (See chapter 7) will be opened and recording commences.
To stop recording select in the **LOG WINDOW** (not the main dashboard) that was opened when starting the realtime log the menu item:

**File--Stop Recording**

or click the ■ button in the toolbar of the log window

Or use the keyboard shortcut **Ctrl-spacebar** when the real time log window is in the foreground.

To record another real time session in the already opened Log Window, either select in the log window menu:

**File--Record New Session**

or click the record button 

or use the keyboard **Ctrl-N** when the real time log window is in the foreground.

## 6.2.1 Triggered Real time Logs

Sometimes it is convenient to start/stop a log not by hand, but automatically when certain conditions are met.

The menu items:

**File--New Triggered Realtime Log** and  
**File--Log Trigger Setup...**

allow you to do that.

Examples are in drag racing, where a run needs to be logged, but there’s no time to select the appropriate menu while waiting in the staging area. Another use is to track down random problems. The trigger condition can be set up to start a session when the problem condition happens. It can then also pre-record a programmable time before the condition happened so one can see what led up to the problem without searching through long sessions. Pre-record includes the programmed number of seconds of data **before** the start condition happened. When waiting for a trigger LogWorks continuously records data, but keeps only the last pre-record seconds and throws older data away. When the trigger happens, the current data buffer is first inserted in the session, followed by the recording.

When selecting the **Log Trigger Setup** menu item the following dialog box will show up:
Trigger Start Condition Setup

In the Log Trigger Start field you enter the session start condition. In the above example the session starts when the Throttle channel indicates more than 50% and RPMs are greater than 3000. Use parenthesis () liberally to indicate conditions.

DO NOT ENTER THE UNITS in the condition equations.

For example DO NOT enter: Throttle > 50%. LogWorks knows the units already from the channel name (Throttle in this case) and does not need to be told.

The persist field allows you to specify a length of time for the condition to persist before the recording is started. This allows eliminating false starts due to for example spikes or glitches.

The Pre-Record field allows you to set a time that LogWorks records before the start condition happened. If set to 60 seconds for example, LogWorks will include in the session the last 60 seconds before the start condition happened. Pre-Record times of up to 300 seconds can be programmed. If a persist time is used, the persist time is included in the pre-record time.

Trigger Stop Condition Setup

Once a recording session has started, it will only stop if the following things happen:

a. The user stops recording with the stop button in the Log Window
b. A stop recording condition has been specified and the condition happened.

In the Log Trigger Stop field you can specify a stop condition. This is done exactly the same way as for a start condition, including the capability to program a persistence time to avoid stopping a log on short glitches and spikes.
In the post-record field you can specify also a time (up to 300 seconds) for which LogWorks will continue to record after the stop condition happened.

After the Stop condition has been satisfied and the recording stopped, you can automatically re-trigger when the “Auto Re-Trigger after Stop Condition” is checked.

When this item is checked, LogWorks will continue to scan the channels for a new start condition and automatically start a new session if the start condition is satisfied.

Stopping the Log manually will cause this scan to also terminate. Manual stopping is performed with:

Select in the LOG WINDOW (not the main dashboard) that was opened when starting the real time log the menu item:

File-->Stop Recording

or click the button in the toolbar of the log window

Or use the keyboard shortcut Ctrl-spacebar when the real time log window is in the foreground.

To restart triggered logging when the real time log window is already open, select in the menu of the log window:

File-->Record New Triggered Session

Be very careful when using the Auto-Re-Trigger function. It is very easy to get LogWorks into an infinite loop where it creates thousands of very short session very quickly.

For example if you select (RPM > 1000) as start condition and (RPM > 7000) as stop condition with auto-retrigger set, you have created an infinite loop when RPMs are bigger than 7000. In this case LogWorks will start to record when RPMs are bigger than 1000. It stops recording when RPMs are bigger than 7000. But that also satisfies the start condition of bigger than 1000. So LogWorks will start and stop sessions very quickly (hundreds per second) if the computer is fast enough. In this example one way to avoid the loop is to specify the start conditions as: (RPM > 1000) AND (RPM < 1060).

Even better would be to specify also a dependency on another channel, like throttle position: (RPM > 1000) AND (RPM < 1060) AND (throttle > 80).

This way the logging starts only if at least 80% throttle and RPM is between 1000 and 1060. In addition, if for example you want in this case logging to stop when you get off the gas even if the redline RPM of 7000 is not reached, you can modify the stop condition to: (RPM > 7000) OR (throttle < 80).

Note the () in this example. Comparisons like RPM > 7000 should always be surrounded by ().
Unique application of Trigger Conditions

One convenient application for the Triggers, when using LogWorks plug-ins, is to use for example OBDII data to start and stop logs without touching a laptop. For example if the position of the rear window defogger switch (bit channel) is used, than you can use:

(Rear_Defogger > 0.5) as Start Condition and
(Rear_Defogger < 0.5) as Stop Condition.

Because Rear_defogger is a bit-channel that can only have the values 0 and 1, the start condition is satisfied when you switch the rear defogger on. The stop condition is satisfied when the rear defogger is off. So the defogger switch becomes a Record Button.
6.3 **Real time Math channels**

LogWorks has a built-in math engine to create new channels from existing channels with mathematical equations. See chapter xxx for details on using the Math Engine. Math channels can be treated like regular value or bit channels. Gauges can be assigned to them as well.

For example it is easy to create a warning gauge indicator for example for a lean condition with the math engine.

For example the formula:

\[ MB(\text{lean\_warning}) = (\text{MAP} > 100) \& (\text{AFR} > 12.7) \]

Will create a bit channel (MB function) named “lean_warning” that becomes active when the manifold pressure channels (MAP) indicates larger than 100 kPa and AFR is leaner than 12.7 AFR.

Similarly all kinds of bit and value channels can be created.

For example if LogWorks records on one channel the engine torque from a dyno, using a load cell, and the torque channel is configured for lbft, then a horsepower channel can be created with:

\[ MC(\text{Power};\text{hp};0;1000) = \text{Torque} \times \text{RPM} / 5252 \]

In this case the new value channel (created with MC) is named “Power” with the unit “hp”, a Range of 0 to 1000 and calculated using the actual channels “Torque” and “RPM.”

---

**⚠️** Math channels are very processor intensive. If your computer is slow you should not use more than one or two.

**⚠️** Some Functions of the Math engine like “slope” or “area” are not applicable for real time math channels. Trying to use those results in an error.

To create a new real time math channel from scratch use

**Channels->Formula Calculator…**

To use some of the existing formulas in the calculator library use:

**Channels->Formula Collection…**
6.4 Viewing existing log Files

Use the Tool in the Main Dashboard Toolbar or use the menu item:

File->Open File Log..

LogWorks can load LogWorks 1, 2 and 3 log files. LogWorks log files have the file extension .log. It can also load files saved in the .dif Format (used with Excel) and .d32 format. The .d32 format is used by the DL-32 device to store logs.

! .log Files store a much more complete log file than either .dif or .d32 files. .log files also store the complete Channel configuration, gauge set, Window positions, charts and so on used when manipulating the log.

After a log is loaded, LogWorks opens a Log Window for that log.

Channel configurations in use during recording or downloading the log file are also part of that file and are applied to the visible channels.

You can change those configurations at any time, but the changes will only affect the log in that file.

6.5 Downloading from an LM-1 or LM-2/DL-32 recorded SD card

When logged data is downloaded from an LM-1 or from an SD card that was recorded on by an innovate device, like the LM-2 or DL-32, the following rules for channel descriptions apply:

Data from a LM-1:

6.5.1 Downloading LM-1 data

To download logged data from an LM-1 use:

File->Import/Download->Download LM-1 log...

Or use the Tool in the Main Dashboard Toolbar.

This creates a new LM-1 log by downloading data internally logged in the LM-1. During downloading the car may not be running (engine off) because the WB sensor’s heater is switched off during downloads. After a download completes, the LM-1 is automatically restarted (heater runs again).

Channels configured from the Main Dashboard that are marked as coming from an LM-1 are applied. If no channels ever were configured, like after LogWorks is used the first time, the channel configuration wizard will ask you to configure the channels.
The LM-1 MUST be directly connected to the serial port of the computer for downloading, not through an MTS chain.

The LM-1 log data can be reset after downloading by selecting:

File->Reset LM-1 log

If you are always using the LM-1 as first device in your log chain follow this procedure to make sure the LM-1 channel configuration is always automatically applied:

1. Configure the channels when the channel configuration wizard shows.
2. Save the downloaded file as .log file.
3. In the main Dashboard window, use File->Import Channel Description... and select and open the just saved .log file. LogWorks will extract the channel description data from the .log file and use it as default for the Dashboard and further LM-1 downloads.

6.5.2 Downloading SD-card (LM-2 or DL-32) data

To download logged data from an SD card insert the SD card in your SD card reader. Then use:

File->Import/Download->Import DL-32 log...

Or use the Tool in the Main Dashboard Toolbar and look for files with the extension .dl32. Browse with the file open dialog box for the removable drive that contains the .dl32 log files.

The .dl32 files contain also information about the devices that contributed to the log and their settings. This is of course restricted to only the recording device itself and devices connected to the recording devices IN port.

LogWorks will search through the channel descriptions it knows about (the ones configured in the Main Dashboard) and will try to match channel descriptions to the contributing devices and their inputs. If no channels ever were configured, like after LogWorks is used the first time, the channel configuration wizard will ask you to configure the channels. It will also ask you for new devices that it did not know about before.

To make sure the new channel descriptions are applied for future downloads follow this procedure:

1. Configure the channels when the channel configuration wizard shows.
2. Save the downloaded file as .log file.
3. In the main Dashboard window, use File->Import Channel Description... and select and open the just saved .log file. LogWorks will extract the channel description data from the .log file and use it as default for the Dashboard and further .dl32 downloads.
6.6 Selecting Representation of the Mixture

Mixture data from one or more Wideband sensors acquired with a LM-1 or LC-1 can be shown as air-fuel-ratio (AFR) or Lambda.

To show the mixture as Lambda or AFR select:

Channels→Show Mixture as Lambda to show it in Lambda or

Channels→Show Mixture as AFR to show air-fuel-ratio

Either setting does NOT change what LogWorks recorded, it changes just the display unit.

Internally LogWorks records always Lambda data.

For display purposes it multiplies Lambda with the stoichiometric setting for the selected fuel. When mixture data is shown as AFR, you can select the fuel type with

Channels→Set Fuel Type→...

When selecting

Channels→Set Fuel Type→Use device Settings

LogWorks will use whatever is programmed as fuel type in the first wideband device in the MTS chain and applies that to all wideband channels.

6.7 And Further

6.7.1 LogWorks Main Window Menu

Use this menu to quickly switch between open logs.

6.7.2 Help Menu

Open this Manual, Show LogWorks Version Number and Copyright and/or go to the Innovate Motorsports home Page.
7 Working with Logs and Sessions

When a Log file is opened, created by downloading, or by recoding realtime, a new Log Window is opened.

7.1 The Log Window

The Log window can be resized to any size. It is divided into different areas and has three or four different panes:

1. Menu area
   Contains the Log menus.

2. Tool Bar.
   Allows selecting the various tools and functions to manipulate the log.

3. Vertical scale Pane
   Shows the vertical scale of the graph for the various channels.

4. Mullions (Pane Dividers)
   Grab the pane dividers with the cursor to resize the panes.

The scale pane (3) shows the vertical scale, the graph pane (6) shows the time traces for the channels, the measurement pane (5) shows the values at the cursor position if the cursor is in the graph pane and the bit channel pane (4) shows the bit channels. Here’s a short description of the parts of the Log Window. The bit channel pane is only visible if there are any bit channels.
5. Measurement pane
Shows the current values of channels under the cursor if the cursor is moved in the graph pane. Moving the cursor over a text note icon shows the content of the text note in the pane. If an overlay session is used, the overlay values are shown in parenthesis () and italics like this: (overlay)

6. Graph Pane
Shows the graphs of the active channels color coded. Moving the cursor over a channel highlights the channel (trace shown in double thickness). Right-clicking on the highlighted channel brings up a menu to manipulate different aspects of the channel. Leaving the cursor on the highlighted channel for a second will show the name of the channel.

7. Time scale area
Click with the + or – tool in the Time scale area to enlarge or reduce the time axis.

8. Note area
In this area notes can be placed to comment events at that point in the session. Notes are indicated by an Icon 😇. Moving the cursor over a note will show the note contents in the Measurement Pane. Double-click on the note Icon to edit the note text. You can also move the note in the note area by clicking and dragging. Some MTS logging devices can record audio comments while logging. If an audio comment is inserted, an audio note icon 🎧 will be shown at the audio comment point. Double-click on the icon to play the audio comment.

To delete a note, drag the note outside the note area.

9. Text Note
Indicates a text note at that point.

10. Measurement Marker
Any number of measurement Markers can be inserted in a graph. The measurement Markers scroll with the graph. A measurement point shows the values of all active value channels at that particular point in time.

11. Bit channel pane.
A bit channels is ON when the horizontal bar assigned to the channel is fat grey. It is off when it is shown as a thin line.

12. Channel Markers
Each displayed channel has a set of 2 markers assigned to it. Only the markers of one channel are shown at a time. The markers are a convenient way to see quickly if a channel value is below or above a certain limit.

13. Session Tabs
Click on a tab to switch to the session represented by the tab.

14. Session length display.
Shows the total length of the session.
7.2 **Navigating Logs**

A log file in LogWorks is divided into Sessions. All Sessions in a log share the same channel Configuration.

7.2.1 **Changing the size of the Panes**

When moving the cursor over one of the Mullions (4) you can drag the Mullions to increase/decrease the size of the adjacent Panes.

7.2.2 **Navigating Sessions**

To switch between sessions, click on the session tab. When switching to a new session AND the new session is shorter than ½ the width of the graph-pane, the new session will be scaled in time so it covers at least ½ the width of the graph pane.

Alternately, you can select a new session with the session Menu:

*Sessions*->*Session Name*

7.2.3 **Scrolling in the Time Axis**

Select the Hand Tool 🧠 in the Task Bar. Alternatively you can select the hand cursor with the menu item:

*Tools*->*Hand Tool* or

the keyboard shortcut Ctrl-H.

The cursor will change to a Hand cursor when it is over the Graph pane, Scale pane, Time Scale, Note Area or Bit Channel pane.

Click on the Graph pane, Time Scale or Bit Channel pane and drag to scroll the Session graph.

You can also scroll in the time axis with the horizontal scroll bar at the bottom of the graph pane.

⚠️ **Keyboard Shortcuts for scrolling:**

- To Scroll quickly to the end of the session, press the **END** key on your keyboard.
- To Scroll quickly to the beginning of the session, press the **HOME** key on your keyboard.
- To Scroll one graph-pane width to the right (later time) press the **Page Up** key on your keyboard.
- To Scroll one graph-pane width to the left (earlier time) press the **Page Down** key on your keyboard.
• To scroll one measuring period (0.08192 seconds) to the right (later time) press the Right Arrow key on your keyboard.
• To scroll one measuring period (0.08192 seconds) to the left (earlier time) press the Left Arrow key on your keyboard.

**Scrolling while real time Logging**

During a real time log the graph pane will scroll automatically to show the most recent data. When scrolling back during a real time log to review a recent event, the autoscrolling will stop to allow examination of the data. Recording will continue even though the autoscrolling is suspended.

To restart the auto scrolling just scroll to the end of the current recording session (for example with the END key) so the real time data is visible again.

**7.2.4 Zooming in and out in the Time Scale**

To Zoom in (Magnify) the time scale select the Zoom In Tool in the toolbar. Then click on the time scale (7) on the time range you want to zoom in on. The point (time) where you clicked will stay on the same place in the scale, but the time will be expanded to the left and right of the click point.

To Zoom out (Reduce) the time scale select the Zoom Out Tool in the toolbar. Then click on the time scale (7) on the time range you want to zoom out from. The point (time) where you clicked will stay on the same place in the scale, but the time will be reduced to the left and right of the click point.

**Holding down the Ctrl-Key when the Zoom In or Zoom Out Tool is selected, changes its function. The Zoom In Tool becomes a Zoom Out Tool and vice versa.**

**7.2.5 Measuring**

The whole point of data logging is measuring. LogWorks provides various tools for that.

Just moving the cursor over the graph pane (6) will update the Measurements in the Measurement Pane (5) to reflect all values of all value channels at the point in time where the cursor position is.

You can also Set Measurement Markers (10) in the Session. A Measurement Marker shows all the measurements of all value channels at the point in time where the Measurement Marker is inserted.
To Insert a Measurement Marker

- Select the Measurement Marker Tool.
- Click (and possibly drag) on the graph pane where you want to Marker Inserted.

To Remove a Measurement Marker

- select the Measurement Marker Tool.
- Click in the Measurement Markers Window

To Remove all Measurement Markers in the Session

Select the Menu Item:

Tools->Delete Measurements

7.2.6 Identifying Channels

When moving the cursor over the graph pane (6) or measurement pane (5) the channel trace (or measurement) over which the cursor resides is highlighted. If you hover (no mouse movement) over a channel or measurement for a second, the channel name is displayed in a small label window.

If the channel is highlighted with the cursor in the graph pane, the corresponding measurement in the measurement pane is shown **bold** and **underlined**.

7.2.7 Marker Lines

Marker lines are dash-dotted lines used to give an easy visual reference to see if a channel trace is above or below a certain value or is in a value range. Marker lines are red (max marker line) and blue (min marker line).

To show Marker lines (12) for a channel:

Either select the channel with:

Tools->Marker Lines->Channel Name
Or click on the measurement item in the measurement pane (5) for that channel.

The channel whose marker lines are shown is identified in the measurement pane (5) in angled brackets like in [14.72 AFR].

To move the marker lines click and drag the marker line handles. While the left mouse button is down on the marker line handles, the exact measurement position of the marker lines and their distance is shown.

**To remove the marker lines:**

Select *Tools->Marker Lines->Hide Marker Lines*

Or click on an area on the measurement pane that’s empty (not showing a measurement),

### 7.3 Manipulating channel traces

#### 7.3.1 The scale pane

The scale pane (3) shows the scales of all visible value channels. If the scale pane is too narrow to show all you can scroll it left and right with the Hand Tool or the scrollbar at the bottom of the pane.

The vertical grid in the graph pane (horizontal lines) reflects the scale of the trace next to the graph pane.

To move a channel scale next to the graph, either use:

*Channels->Set Grid To->Channel Name*

Or right-click on the channel scale in the scale pane. A popup menu will show up that allows you to move the scale next to the graph and set the grid to that channel.

**Channel Grouping**

If multiple channels have:

a. The same unit
b. The same range
c. The same Zoom in magnification and vertical scroll position

The scale pane will show only one scale for all those channels by grouping them. This is also reflected in the name shown next to the scale.

If a channel would belong to a group, but has a different Zoom in magnification or vertical scroll position, you can force it’s Zoom in magnification and vertical scroll position to be the same as the rest of the channels in the group by right-clicking on the channel scale and selecting in the popup menu: *Group with others of kind*
With the same popup menu you can also change the position of the channel scale in the scale pane.

### 7.3.2 Zooming in and out on a channel trace

**To zoom in on a channel trace**

use the Zoom In Tool in the toolbar and click on the channel trace in the graph pane.

**To zoom out a channel trace**

use the Zoom Out Tool in the toolbar and click on the channel trace in the graph pane.

A magnified channel trace can then be scrolled up or down with the Hand Tool.

Alternatively, you can use the Zoom In, Zoom Out and Hand tools also on the scale of the channel in the scale pane (3).

If the scale pane shows a group of channels, you can zoom in/out and scroll the entire channel group at once by using the Zoom Tools or Hand Tool in the scale pane on that channel group.

### 7.3.3 Smoothing channels

Smoothing can be used to better see trends and is necessary for some calculations (specially those involving calculating slopes). Smoothing is a running average of a sample of a channel with its neighbors in time (both before and after). Smoothing should NOT be used to get rid of excessive noise in a channel, for example spikes caused by ignition misses. Because smoothing is an averaging operation, the lean-spikes caused by ign. misses would be included in the AFR values and would bias them towards leaner values.

To smooth a channel either select in the Log window menu:

**Channels-->Smooth Channel-->Channel name**

Or right click on the channel trace in the graph pane. The popup menu showing up then also allows you to smooth the selected channel.

**When right clicking on a channel group in the scale pane** and selecting smoothing from there, you can smooth all the channels in the channel group at once.

When selected, the following dialog box will appear:

![Smooth RPH](image)

This allows you to ‘smooth’ a channel. The smoothing slider allows smoothing a trace by replacing each data point with the running average of its neighbors and itself. The position of the slider determines how many of the neighbors are included in the running average (0 to 32 neighbors on each side).
7.3.4 Hiding/Showing channels

The popup menu showing up when you either right-click on a channel’s scale in the scale pane or on the channel in the graph pane allows you to hide, but not show channels (obviously because the channel is hidden, ergo you can’t right-click on it).

To show/hide many channels quickly use the Log window menu:

Channels→Show/Hide channels…

Or click the Show/Hide Tool in the toolbar.

This brings up the channel show-hide dialog box. In this dialog box channels with the same unit and range are grouped together so you can hide/show all the channels in a group together.

7.3.5 Deleting channels

If you definitely, positively do not need a channel anymore you can delete it with
Channels->Delete Channel->Channel Name
This function is irreversible. All the channel data and channel configuration will be deleted.

7.3.6 Configuring Channels

From a Log Window you can configure the channels in a Log as described in chapter 4. All the info in that chapter applies, including fuel type selections as described in chapter 6.4.

⚠️ Any channel configuration change done from the Channels menu in a Log Window applies ONLY to the log shown in the window. One exception is for real time logs that have not been saved. In that case the change is also reflected in the Main Dashboard.

7.3.7 Math Channels

LogWorks has the capability to create calculated channels from existing data channels. See chapters xxx and xxx for details.

7.3.8 Channel Templates

A channel template contains (for all channels in a log)

- Is the channel shown or hidden
- How much is the channel smoothed
- How much is the channel zoomed and scrolled
- Which gauges are assigned to which channel and their position in a log playback window.

To save the current channel settings in a template, select in the Log Menu:

Templates-->Template Manager…

The Template manager window will appear:
It shows the currently stored channel templates. Enter a new template name and click save. To rename a template, select it in the list and enter a new name. Then click Rename. To delete a template, select it in the list and click delete.

To select a already stored template, select in the in the Log Window menu

Templates->Template name

When a template is selected you will be asked if the stored smoothing should be applied to:

- the current session
- all sessions in the log
- not applied (left as is)

⚠️ When a log is newly created by real time logging, or downloading from an LM-1 or DL-32, the templates are stored in the LWSsettings file and will be available after further downloads.

If a log file is already saved, or loaded from a .log file created by Logworks 2 or 3, the templates are stored in the log file itself.
7.4 Selecting areas in a Session

For processing the log data it is often necessary to exclude certain areas in a session. Examples are transitional events like acceleration enrichment when calculating air-fuel charts.

To highlight or select certain areas in a Session use the Selection Tool.

Or use Tools->Selection Tool

Click and drag on the area in the graph pane you want to select.

Whenever you click with the Selection Tool on the graph (without any modifying keys pressed) all previously selected areas are deselected.

To select multiple areas:

hold down the Ctrl-key while clicking and dragging with the Selection Tool. This prevents previously selected areas from becoming deselected.

To extend a selection, hold down the shift key while clicking on the graph pane. The last inserted selection will be extended to where you clicked the shift key.

7.4.1 Inverting a selection

When inverting a selection all previously selected areas are deselected and all selected areas become selected. This can be performed with the log menu items:

Edit->Invert Selection or
Edit->Invert Selection in all Sessions

The second case applies the command to all sessions in the log.

7.4.2 Auto Selecting and Searching

Autoselect is a very powerful tool to select areas of interest in a session. With autoselect you can specify search terms for specific conditions. If the search term evaluates to TRUE (for example if the term is \( \text{AFR} > 14.7 \)), all the areas in the session where the term is true are selected, all others are deselected.

To autoselect use

Edit->Search...

Or click the search button in the Log Window toolbar or use the keyboard shortcut Ctrl-F.

This brings up the following dialog box:
In the window of this dialog box you can specify search terms like “AFR > 14.7” and so on. You can then connect these terms with ‘AND’ or ‘OR’. LogWorks will process the entire session and select those areas which satisfy the search criteria. In the above example all lean spots leaner than 14.7 AFR are selected where the throttle position is bigger than 60%.

Note the parenthesis around the search terms. These parenthesis are important. The search engine evaluates each term whether it is true or false. A false term is zero, a true term is not zero. If for example the parenthesis around (AFR > 14.7) were omitted, the search parser engine would evaluate first if AFR is zero or not, then see if that result is > than 14.7 which would produce unexpected results.

When using a bit channel in the search, you can just enter the bit channel name. A bit channel can only be true or false.

So a term like:

Bit_channel1 AND (Throttle > 60) is perfectly fine. In this case the search result is true when bit_channel1 is true and the throttle channel is bigger than 60%.

**Do not specify a unit (like % after 60% or PSI after 0 PSI).**

Note that the input names are case sensitive. Afr would be different than AFR. Make sure you type the input name correctly. Click on the ‘Add to Search Library’ button to add the search term to a search library. The search library holds frequently used searches. When clicking the button a dialog will show up that will allow you to specify the name, category and comment for the library entry. See chapter xxx for details.

**A special bit channel name that is always specified, but not visible as real bit channel has the name:**

_S_
This represents the current selection as bit channel. This allows you to manipulate current selections without replacing them wholly with the search result. It can also be used to sequentially refine searches.

So for example if you manually already selected (or with a different autoselect) some areas, you can specify (Throttle > 60) AND _S_. This will modify the selection so that only the areas that are already selected are searched for throttle > 60%, narrowing the search.

Conversely if you specify (Throttle > 60) OR _S_, the areas where throttle is bigger than 60% are added to the existing selections, extending the selections.

You can save frequently used searches in a search library. See chapter xxx about using LogWorks libraries.

7.4.3 Scanning through selected areas

To quickly scan through a log use:

**Edit->Goto Next Selection**

Or use the keyboard shortcut **Ctrl-G**

This menu item (equivalent to a search function) jumps directly to the beginning of the next selection created by for example the Autoselect function. It also puts a temporary measurement point there.
7.5  Working with Sessions

As explained in previous chapters, a Session in LogWorks is a contiguous recording. Sessions have a length, a name, comments, a recording date (or not) and are associated and belong to a log. How to switch the Log Window view between sessions was already explained in chapter 7.2.2.

To view information about a session move the mouse over the tab of the session (13) you want to see information about. A popup balloon window will show the recording date/time, length and comments for the session.

7.5.1  Changing session information

In the Log Window menu select:

Sessions->Show Session Info

This brings up this dialog box that shows information about the currently shown session:

If the record time and date is unknown (for example for a session recorded in an LM-1), the current time and date is shown. You can change the time and date for a session by editing the appropriate field.
By default the sessions in a log are sequentially numbered. Change the session name to something more easily remembered.

7.5.2  Notes and comments
In the comment section of the above window you can type comments about the session.

To insert comments (notes) at certain times in the session, select the Note Tool in the toolbar of the Log Window.

Then click on the note area (8) below the time trace in the Log Window where you want the note to be placed. Once placed, a dialog box will show up that allows you to enter the text for the note. Close the dialog box after you entered the note text.

**Moving a Note**

You can drag a note icon to any place in the note area.

**Viewing a Note**

Hover with the mouse over a Note icon in the note area. The contents of the note are shown in a popup window.

**Editing a Note**

Double click the note Icon. A window with the note content will show and you can edit the note.

**Deleting a Note**

Drag the note icon down out of the note area towards the scrollbar at the bottom of the graph pane.

### 7.5.3 Deleting a whole Session or parts of a session

As explained, a session is a contiguous recording. Therefore it is not possible to delete a part of a session in the middle. It is however possible to delete part of a session at the end or beginning.

**To delete part of a session**

click with the selection tool at the beginning of the part you want to delete. Then drag to the end of the session. Or drag to the begin of the session if you want to trim off the beginning part of a session.

Then select in the Log Window Menu:

**Edit--->Delete Selection**

Or hit the Delete key on your keyboard.

To delete a whole session, switch to the session to be deleted and select in the Log Window menu:

**Edit--->Delete current session**

or use the keyboard shortcut

**Shift-Delete key** (shift key held down while pressing the Delete key)
A log MUST have at least one session. Therefore the last session in a log can't be deleted.
7.5.4 Copying and Pasting

To copy a session or part of a session onto LogWorks’ internal clipboard select either the whole session with:

Edit->Select whole Session

Or the keyboard shortcut Ctrl-A

Or select any part or parts of a session you like.

Then use:

Edit->Copy

Or the keyboard shortcut Ctrl-C

This will copy the selected parts of the session into LogWorks’ internal clipboard as well as on the computer’s clipboard.

You can then paste the session data (if the selection was contiguous) as new session in the current log, or, if the channel configurations match, into another log. In this case both logs must be open at the same time. LogWorks can open up to 16 logs at the same time in 16 different log windows.

Paste with:

Edit->Paste as new session

Or press the Insert key on your keyboard.

⚠️ The session data is also copied to the computer’s internal clipboard as tab delimited text. You can paste that text then into any program that accepts tab delimited text like Excel, Word or any text editor.

7.5.5 Overlays

You can also paste the copied session data onto another session as overlay. Overlays are a convenient way to compare two sessions graphically.

To paste copied session data as overlay use:

Edit->Paste as Overlay

Or use the keyboard shortcut Ctrl-V.

The traces of the overlay are shown as dashed instead if solid as in the example below:
Using the overlay scroll tool ▶️ in the Log Window toolbar you can move the overlay left and right. If a measurement marker overlaps an overlay trace, the overlay measurements at this point are shown in brackets () and italic. The hand tool ✧ or horizontal scroll bar moves underlying graph and overlay together. Overlays are not saved with a log.

**To remove the overlay**

Use **Edit→Remove Overlay**

Or the keyboard shortcut **Alt-O**

### 7.6 Saving, exporting and Printing

To save a log use:

**File→Save…** (keyboard shortcut Ctrl-S) or

**File→Save As…**

You can also save the currently viewed session into a separate log file with:

**File→Save current session only…**

### 7.6.1 Exporting to different file formats

Logs can be exported in the following formats:

- **Data Interchange Format .dif**
  This format can be read by many spreadsheet programs. LogWorks can also open logs saved in .dif format.

- **Comma delimited Text .csv**
  This format is used by many other logging programs. It can also be loaded by many spreadsheet programs.

- **Bosch MDF Format .mdf**
  This format is used by Bosch and ETAS data analyzing software. When saving in this format the individual sessions of a log (if the whole log is exported) are saved as individual files.

Individual Sessions can also be exported in tab delimited text format (.txt):
To export to different file formats use:

File->Export Log in->File Format or
File->Export current session in->File Format

7.6.2 Printing Logs

Select File->Print...
Prints the log or current session. A print dialog box like below appears:

This dialog is divided into four sections:

In the ‘Printer’ section select the printer to use. Usually you do not need to touch this section.

The ‘Print range’ section allows you to select the time range you want to print. Also selects whether you want to print the content of all the text notes as well.

The ‘Presentation’ section allows you to select if you want to use the current time scale, of if it is to be scaled 1:1 in time, or if the entire session is to be scaled to fit on one page.

The ‘Show vertical scales’ section allows you to select if you want to show the vertical scales on the left of the graph on every page or only on the first one. Showing it only on the first page allows you to glue the pages of a long session together as a strip-chart.
7.7 Alternate Views of Sessions and Logs

LogWorks has five built-in methods to view the logged data.

1. Log Time Trace View (the Log Window, this chapter)
2. Playback View (see chapter 7.7.1)
3. Statistic View (see chapter 7.7.2)
4. X-Y Plot View (see chapter 8)
5. 3D Chart View (see chapter 9)

For each open Log in LogWorks you can have simultaneously open up to:

1 Log Time Trace View Window
1 Playback View Window
16 Statistic View Windows
4 X-Y Plot View Windows
4 3D-Chart View Windows

To easily find a view window and bring it to the foreground select for

Statistic Views:
View->Statistics…->Channel Name

X-Y Plot Views:
View->XY-Plots->XY-Plot Window Name

3D-Chart Views:
View->View Chart->Chart Window Name

You can also re-size and reposition all the open views easily with:

View->Cascade Windows (keyboard shortcut Ctrl-T)

7.7.1 Playback

A session can be played back from the Log Window to get a sense of time for the different events. A playback window is similar to a recording of a car’s dash.

Use in the Main Log Window

File->Playback

Or press the playback button in the Log Window toolbar

This brings up the Play Window.
The gauges in the playback window can be manipulated the same way as described in chapter 3. The position, type, number and channel assignment of the gauges and of the playback window is saved in the log file when log file is saved. The current gauge skin selected in the Main Dash is also applied to a playback window, independent of the skin the log was originally saved in. When opening a playback window the first time, the position, type, number and channel assignment of the gauges in the current Main Dash active during the time the log was saved or created is applied.

With this window you can play, single-step forward and back and loop on an area. You can also change the playback speed. If areas in a session are selected, only the selected areas are played. When playing back while a 3D chart/graph is open (see chapter xxx) the play position is also indicated in the chart/graph.

### 7.7.2 Statistics Views

Open a statistics window with the Log Menu item:

**View-->Statistics-->Channel Name**

This submenu opens a statistics window for the selected input. A statistics window looks like this:
This window shows how often a certain input value happened during a session or partial session. If nothing in the graph is selected, the Statistics window represents the data of the entire session. If a part of the session is selected (Selection Tool), only the data of the selected areas is represented.

The vertical axis is automatically scaled relative to the highest occurrence. The horizontal axis is automatically scaled to the range of the input with the session or selection. In addition the window shows how many data points (time) are represented, the average of the selected data and the minimum and maximum points in the selected data range or entire session.

⚠️ **Manipulating the session data with the smoothing filter, changing selection or adding/deleting measurement points will be automatically represented in the statistics.**

### 7.7.3 Opening X-Y Plot Views

Open an X-Y Plot View with the Log Window menu Item:

**View**→**New XY Plot...**

Or keyboard shortcut **Ctrl-Y**

This opens a new X-Y plot with default channel assignments.

Or click on the New XY Plot button in the Log Window toolbar. When clicking on the New XY Plot button, the last opened XY Plot settings are applied. If there have not been any xy-plots opened yet, the default channel assignments are used.

A X-Y Plot is a plot of the session data with one channel (for example RPM) on the X axis and other channels (like AFR, torque, power…) on the Y axis.

This is similar to a dyno graph. See chapter 8 for details.

You can also open XY-Plots from stored XY templates with:
**View->XY From Template->Template Name**

If any XY Plot templates are stored in either the Log File or the generic LWSettings file. If there are templates in both, the menu will indicate that. Templates that can’t be applied because the associated channel names have changed, are grayed out. For details on how to store XY Templates, see chapter 8.

### 7.7.4 Opening 3D charts

Open a 3D chart View with the Log Window menu Item:

**View->New Chart**

Or click on the New Chart button in the Log Window toolbar.

When clicking on the New Chart Plot button, the last opened chart settings are applied. If there have not been any charts opened yet, the default channel assignments are used.

With this item a new 3D chart can be specified. A 3D chart is a table (or graph) that shows the contents of a channel as dependent on two other channels as in this example:

![3D chart example](image)

This example shows average AFR over Manifold Pressure and RPM.

The fuel map or ignition map of an electronic fuel injection system is a typical example for such a map. **For further details see chapter 9**

When the **New Chart** menu item is selected, the following dialog box will show up:
This allows you to select the x- and y channels, the content channel and the range and number of steps for the initial chart settings. Don’t fret on the number of channels and range though. Once the chart is created, you can always manipulate the spacing and number of the columns and rows of the chart.

You can also open 3D charts from stored 3D chart templates with:

**View->Chart From Template->Template Name**

if any chart templates are stored in either the Log File or the generic LWSettings file.

If there are templates in both, the menu will indicate that. Templates that can’t be applied because the associated channel names have changed, are grayed out. For details on how to store chart Templates, see chapter 9.4.
8 X-Y Plots

An X-Y Plot is a View of a log where the data is sorted along a specified channel (x-axis) and the vertical axis shows other channels in their relationship to the x-axis channel.

This is an X-Y Plot in Cartesian coordinates showing power, torque and AFR over RPM.

The X-Y Plot window can be resized to any size. It is divided into different areas and has 2 different panes:
- The scale pane (4) shows the vertical scale, the graph pane (3) shows plots of the channels.

Here’s a short description of the parts of the X-Y Plot Window.

1. **Menu area**
   Contains the XY menus.

2. **Tool Bar.**
   Allows selecting the various tools and functions to manipulate the X-Y Plot.

3. **Graph Pane**
   Shows the graphs of the active channels color coded.

4. **Vertical scale Pane**
   Shows the vertical scale of the graph for the various channels.

5. **X-Axis scale**
   Shows the scale of the selected X-axis channel.

6. **Measurement Time**
   Shows the amount of accumulated time in the session contributing to the X-Y Plot.
8.1 Selecting the channels to plot

Select the X-Axis channel with the X-Y Plot Menu:

X-axis->Channel Name

Any number of Vertical channels can be selected with:

Y-axis->Channel Name

You can also quickly select multiple channels with:

Y-axis->Show/Hide...

This brings up a dialog box that shows all selectable channels for the Y-axis (vertical axis)

Or click the Show/Hide Tool in the toolbar

This brings up the channel show-hide dialog box. In this dialog box channels with the same unit and range are grouped together so you can hide/show all the channels in a group together.
8.1.1 XY - Templates

By default, if not specified different, a new X-Y Plot window will show the first channel in the
channel list for the Y-axis and the second channel in the channel list for the X-axis.

To save a template select:

Views/Command->Template Manager...

The Template manager window will appear:

It shows the currently stored XY-Plot templates. Up to 16 XY-plot templates can be stored in each
of the current log file or in the generic LWSettings file. To save the current XY-Plot settings as
template enter a new template name and click save. To rename a template, select it in the list
and enter a new name. Then click Rename. To delete a template, select it in the list and click
delete.

When “Generic Templates” is checked, the template is stored in the LWSettings file and is
subsequently available for all further logs.
When “File only Templates” is checked, the template is only stored in the log file from which this
X-Y Plot has been opened. This allows log files to “carry” associated templates.

8.2 Selecting the data to show

The X-Y Plot will show usually all selected areas in the current session in the Log Window. If
nothing is selected, all the data in the current session is used for the X-Y Plot.
Changing the selection in the Log Window will automatically update all X-Y Plots open for that log.

8.3 X-Y Plot representation

The X-Y Plot can show the channel date as scatter plot, line plot or text table.

8.3.1 Scatter Plot

Select scatter plot view with:

Views/Commands->View as scatter Plot

Or click on the scatter plot button in the X-Y Plot toolbar.

A scatter plot looks like this:

Each data point is shown with a little x.
If overlays are on the current session (see chapter 7.5.5), then the overlay data points are shown as little squares.

8.3.2 Line Plot

A line plot connects all the data points with lines in the order in which the data points are recorded.

Select line plot view with:

Views/Commands->View as line plot

Or click on the line plot button in the X-Y Plot toolbar.

A line plot looks like this:

If overlays are on the current session (see chapter 7.5.5), then the overlay data point lines are shown dashed.
8.3.3 Text Table View

Text table view shows all the data points sorted by the X-axis channel. Like in this:

<table>
<thead>
<tr>
<th>RPM (RPM)</th>
<th>LM1_O2 (AFR)</th>
<th>torque (lbf)</th>
<th>power (hp)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1300</td>
<td>13.53</td>
<td>65.5</td>
<td>16.2</td>
</tr>
<tr>
<td>1310</td>
<td>13.57</td>
<td>66.2</td>
<td>16.4</td>
</tr>
<tr>
<td>1320</td>
<td>13.51</td>
<td>66.6</td>
<td>16.7</td>
</tr>
<tr>
<td>1340</td>
<td>13.57</td>
<td>67.1</td>
<td>17.1</td>
</tr>
<tr>
<td>1360</td>
<td>13.61</td>
<td>67.5</td>
<td>17.4</td>
</tr>
<tr>
<td>1370</td>
<td>13.55</td>
<td>68.1</td>
<td>17.7</td>
</tr>
<tr>
<td>1380</td>
<td>13.47</td>
<td>68.6</td>
<td>17.9</td>
</tr>
<tr>
<td>1400</td>
<td>13.49</td>
<td>69.0</td>
<td>18.4</td>
</tr>
<tr>
<td>1420</td>
<td>13.43</td>
<td>69.6</td>
<td>18.7</td>
</tr>
<tr>
<td>1450</td>
<td>13.43</td>
<td>70.1</td>
<td>19.0</td>
</tr>
</tbody>
</table>

The leftmost column is the x-axis by which the other channels are sorted. The columns to the right are the Y-axis channels. The minimum of each channel is highlighted in blue. The maximum is highlighted in red.

To quickly find the minimums, use the Zoom Out tool in the toolbar and click on the column of the channel you want to search.

To quickly find the maximums, use the Zoom In tool in the toolbar and click on the column of the channel you want to search.

You can also copy the entire table as tab delimited text onto the clipboard of the computer with:

Views/Command->Copy Table to clipboard

This can be subsequently pasted into other programs that accept tab delimited text like Excel, Word and so on.

Overlaid data is not shown in the text table view.
8.4 Zooming and scrolling the view

This sub-chapter is only applicable if the X-Y Plot does NOT show a text table.

8.4.1 Increasing the axis resolution

To increase the resolution of an axis channel

use the [Zoom In Tool] in the toolbar and click on:

a. The x-axis scale to increase the resolution of the x-axis.
b. A y-axis scale to increase the resolution of the y-axis of that channel.
c. The graph pane to increase the resolution of both x and y axis IF ONLY ONE Y-CHANNEL SCALE IS SHOWN. Otherwise clicking on the graph pane ONLY increase the x-axis resolution.

Increasing the resolution means less of the channel’s range is shown in the graph pane, but it is shown with higher resolution.

8.4.2 Reducing the axis resolution

To reduce the resolution of an axis channel

use the [Zoom Out Tool] in the toolbar and click on:

a. The x-axis scale to reduce the resolution of the x-axis.
b. A y-axis scale to reduce the resolution of the y-axis of that channel.
c. The graph pane to reduce the resolution of both x and y axis IF ONLY ONE Y-CHANNEL SCALE IS SHOWN. Otherwise clicking on the graph pane ONLY reduces the x-axis.

Increasing the resolution means more of the channel’s range is shown in the graph pane, but it is shown with lower resolution.

If only part of the channel’s range is shown, the visible part of the channel’s range can be changed by scrolling.

8.4.3 Scrolling

Use the [hand tool] in the toolbar and:

a. Click and drag the x-axis scale to scroll in the x-axis (if enlarged)
b. Click and drag on a y-axis scale to scroll the y-axis channel (if enlarged)
c. Click and drag in the graph pane to scroll both the x and y axis IF ONLY ONE Y-CHANNEL SCALE IS SHOWN.

8.4.4 Auto scaling the x-axis
Select in the X-Y-Plot menu:

**Views/Command->Autoscale X axis**

This will automatically scale and scroll the x-axis such that the actual recorded data range of the x-axis channel fits exactly in the graph pane.

### 8.5 Marker Lines

Marker lines are dash-dotted lines used to give an easy visual reference to see if y-channel data is above or below a certain value or is in a value range. Marker lines are red (max marker line) and blue (min marker line).

To show Marker lines for a Y-channel:

Select the channel with:

**Info->Marker Lines->Channel Name**

To move the marker lines click and drag the marker line handles. While the left mouse button is down on the marker line handles, the exact measurement position of the marker lines and their distance is shown.

To remove the marker lines:

Select **Info->Marker Lines->No Marker**

### 8.6 Min Max Info

To show the Min and/or Max value of a Y channel shown in the X-Y Plot in reference to the X-axis channel, select:

**Info->Show Max Value->Channel Name** or **Info->Show Min Value->Channel Name**

A Min/Max Window will show in the graph pane:
Click and drag the Min/Max window with the hand tool to reposition it to a convenient spot.

To hide or show the Min or Max values of all Y channels, select

- **Info->Show Max Value->Show all**
- **Info->Show Min Value->Show all**
- **Info->Show Max Value->Hide all**
- **Info->Show Min Value->Hide all**

### 8.7 Channel Identification

To easily identify the channels by color a legend window can be opened with

**Info->Show Legend...**

### 8.8 Polar Coordinates

Cartesian coordinates are normally used in the X-Y Plot. In the Cartesian coordinate system data is drawn on a rectangular grid defined by the X and Y-axes. The scales of X and Y units do not necessarily have to be the same, in fact they usually are not. Examples could be AFR on one axis and manifold pressure, throttle position or RPM on the other.

The Polar coordinate grid system is circular and centered at the origin (intersection) of an x-y coordinate system. The scale is the same in all directions. The values are shown as a distance and a direction from the center. It could be thought of as a rotary bar graph. In this case the center represents zero and the length and angle of the indicator line represents the magnitude and vector (direction) of the measurement. Similar to a bull’s-eye shooting target where the score is measured as distance from the center, but in this case the center is zero and further from the center is a larger measurement.

A circular graph is useful when analyzing the "g" forces of acceleration, braking and turning left or right that act at any direction in a horizontal plane relative to the vehicle. The forces are measured by the X and Y axis accelerometers in the DL-32 or LMA-3 and the combined force magnitude is represented as a distance from the center (no force) and it’s acting direction as the angle of a line drawn from the center to the combined force point.

**Polar Coordinate View can only be used (and only makes sense) if both X and Y channels have the same unit.**

To switch to polar coordinate view use:

**Views/Command->Polar Coordinate View.**

Polar Coordinate View with Marker lines:
This plot is in memory of vintage racer Dick Ott, who was the driver/owner of the car during recording of this log.

In this example right turning and accelerating are assigned positive values and left turning and braking are negative. Even though Polar coordinates are essentially value and angle, by convention the normal cartesian axis labels are used to make the view easier for a novice to interpret.

Polar Coordinate View imposes the following restrictions:

a. **Zooming will always happen in both axis.**
b. **No auto scale in X-axis allowed.**
c. **Only channels with the same unit are allowed for the axis**

### 8.8.1 Marker Lines in Polar View

Vertical and horizontal Marker Lines (limit indicators or redlines) do not apply in a Polar Coordinate View. Instead, a perimeter limit marker, the dashed blue line in the example above, defines an elliptical shape formed by quarter-elliptical segments between the four markers on the horizontal and vertical axes, consisting of (clockwise):

a. The max. marker position in the vertical direction (12:00 o’clock) and max. marker position in the horizontal direction (3:00 o’clock).
b. The max. marker position in the horizontal direction (3:00) and min. marker in the vertical direction (6:00).
c. The min. marker in the vertical direction (6:00) and min. marker in the horizontal direction (9:00).
d. The min. marker in the horizontal direction (9:00) and max. marker in the vertical direction (12:00).
Clicking on one of the four rectangular handles allows you to drag that marker position. While the mouse button is down the exact value of that marker position is shown.

The ellipse quadrants are focused at the origin of the x-y coordinate system, which is the center point of the polar coordinate view.

### 8.8.2 Interpretation example of Polar View

The above example shows all the side-force and acceleration/braking data points of a 42-minute road course session recorded with an LC-1 and DL-32.

The marker lines are adjusted in this case to approximate the traction limit of the car and it's tires.

On the upper half of the graph the data shows that the driver did a good job when accelerating out of turns. The measured force points are close to the traction limit of the car. The plot indicates less force as the acceleration approaches straight ahead because the car can turn with more force than it has power to accelerate and the straight-line acceleration is in the higher gears on that particular track.

On the lower half of the graph the data shows he did not take full advantage of the available traction on turn entry while braking. The plot has a marked peak toward the bottom (braking in a straight line), but he did not stay at the traction limit when turning into the corners, particularly to the left (shown in the lower left quadrant), as there is rarely any combined force of braking and sideforce at the traction limit in the lower right and left quadrants. This is evident by the un-filled area between the traction limit indicated by the perimeter marker lines and the actual data plot.

After seeing this data and getting some “consultation” from his crew and friends/competitors, this driver improved his lap times over two seconds in a two-minute lap.
9 3D charts and graphs

3D charts are tables or graphs showing the dependency of a selected channel (content channel) in relation to two independent other channels. The independent channels (x and y axis) are divided into variably sized sections. The values of the content channel are sorted into ‘bins’ dependent on the content of the x-y channels. The average value, standard deviation, number of data points contributing and the max and min for each bin are calculated.

9.1 The 3D chart window

The Chart window can be resized to any size. It is divided into different areas and has three different panes:
- The colorizing pane (5) allows selecting the color range if colorizing is selected, the chart/graph pane (6) shows the values of the selected sub-chart and the measurement pane (8) shows the values at the point of the cursor when the cursor is in the chart/graph pane. Here's a short description of the parts of the Chart Window.

1. Menu area
   Contains the Chart menus.

2. Tool Bar
   Contains buttons for frequently used menu commands.

3. Chart Selection Tabs
Allows switching between displaying the sub-charts. Just click on the tab. The standard sub-charts that are always generated are:

a. Average (average value for the bin)
b. Standard Deviation (statistical standard deviation for the bin). A bin where the standard deviation can’t be calculated (Number of data points less than 2) will be shown as ---.
c. Number pts: Number of data points in that bin
d. Max: the maximum value of all data points in the bin
e. Min: the minimum value of all data points in the bin

4. User charts

Use charts are sub-charts that can be filled out/edited by the user, can be pasted into or can be the result of a chart calculation. User charts can also be filled out by LogWorks plug-ins. They can be for example filled out by downloading the current fuel table from the ECU with the correct plug-in for the ECU.

5. Colorizing pane

Allows colorizing the chart according to different values. See chapter xxx for details.

6. Chart/Graph pane

Shows the values of the bins of the selected sub-chart.

7. Chart bins

8. Measurement pane

Shows the values of all sub-charts of the bin over which the cursor currently is. Resize the measurement pane by grabbing its left border.

9. Column Headers

10. Row Headers

9.2 Selecting data to base the chart on

In the Sessions menu you can select which sessions the chart is calculated from. You can also specify to base the chart on only the selected areas in the sessions. For details about selections, see chapter 7.4.

For many chart calculations it is important that only relevant sections in a log are selected. For example for an air-fuel chart used to calculate fuel maps for an ECU it is important that transitional events like acceleration enrichment, deceleration fuel cutoff, warm-up enrichment are NOT included in the chart creation as those would skew the averages used to measure the chart.

Use the selection tool in the Log Window, the auto search function and so on to find those areas. Then invert the selection so that those areas are excluded.

9.2.1 Locking a chart

If you want to prevent that a chart is updated everytime you change a selection in the log/session, you can “lock” it. This means the data in the charts is preserved, despite any changes of selection in the originating log/session. To lock/unlock a chart, use:
Edit->Lock Chart

To lock and unlock the chart. The “Session” menu will be grayed out and unusable when the chart is locked.

This allows for example to open more chart windows with different selection criteria without affecting the locked charts.

9.3 Manipulating the chart settings

9.3.1 Adding a column or row

To add another row or column in the chart, click on the column or row header where you want to insert a new row or column. Then select in the chart menu:

Edit->New column to left or
Edit->New column to right

if you want to add a column, or

Edit->New column above or
Edit->New column below

if you want to add a new row. The value of the new row/column header is initially the average of the neighboring row or column headers. You are free to change it to anything you like. See below:

9.3.2 Changing row or column header values

To change the value of a column or row header, double-click on the column or row header. The column/row entry will become editable:

When you are done entering a new value, hit the ‘Enter’ key to make the change permanent. The row/column will be inserted at the right place in ascending order.

9.3.3 Copying/pasting row and column settings

To copy row and column settings, select the column/row headers you want to copy by clicking and dragging over the entire header so it is highlighted. Then select in the chart menu:

Edit->Copy Selection

Or use the keyboard shortcut Ctrl-C.
To paste new values in the row and column headers, select the rows or columns which you want to replace with the copied settings. Then select in the chart menu:

**Edit->Paste Settings**

⚠️ **You can also paste in settings created by other programs like Excel as long as these programs put the values as tab-delimited text on the clip-board of the computer.**

### 9.3.4 Changing the Chart channels

To change the chart channels, select in the chart menu:

**Table->Table Setup...**

or click on the chart setup button in the toolbar

![Chart Settings](chart_settings.png)

If you just change the content channel, the current row and column settings of the chart will stay untouched. If you change either of the axis channels, the settings for that axis (rows or columns) will change to be equally spaced with the number of steps and end values specified in this dialog box.
9.3.5 Deleting rows or columns

Select the rows or columns to delete, then select in the chart menu:

Edit->Delete Selection

9.4 Chart Templates

Chart templates store the current channels used for a 3D chart, their assignment to the axis, the axis spacing, the view type (graph or chart), color scheme and assignment, and any user chart data used in the chart.

To save a template select:

Table->Chart Template Manager...

The Template manager window will appear:

It shows the currently stored 3D chart templates. Up to 16 3D chart templates can be stored in each of the current log file or in the generic LWSettings file. To save the current chart settings as template enter a new template name and click save. To rename a template, select it in the list and enter a new name. Then click Rename. To delete a template, select it in the list and click delete.

When “Generic Templates” is checked, the template is stored in the LWSettings file and is subsequently available for all further logs.

When “File only Templates” is checked, the template is only stored in the log file from which this 3D chart has been opened. This allows log files to “carry” associated templates.
### 9.5 Colorizing a chart

You can color a chart by average value, Standard Deviation or Number of data points. You can also choose between 4 different color schemes. The Colorize pane will become active as shown below.

To quickly colorize a chart by the average value, click on the colorizing button in the toolbar.

To colorize you can also select in the Chart menu:

- Colors->Colorize by average value
- Colors->Colorize by standard deviation
- Colors->Colorize by number of datapoints.

**By moving the Max and Min tabs you can limit the colorization to the value range you are interested in. The range can be limited to as small as 10% of the total range of the channel.**

**If colorizing by Number of data points the scale for the colors is logarithmic.**

Example of a colorized chart:

<table>
<thead>
<tr>
<th>Throttle (%)</th>
<th>RPM</th>
<th>LM1_O2 (AFR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.0</td>
<td>111</td>
<td>2222</td>
</tr>
<tr>
<td>10.0</td>
<td>15.04</td>
<td>18.18</td>
</tr>
<tr>
<td>20.0</td>
<td>14.98</td>
<td></td>
</tr>
<tr>
<td>30.0</td>
<td>14.94</td>
<td></td>
</tr>
<tr>
<td>40.0</td>
<td>14.42</td>
<td></td>
</tr>
<tr>
<td>50.0</td>
<td>14.67</td>
<td></td>
</tr>
<tr>
<td>60.0</td>
<td>14.09</td>
<td></td>
</tr>
<tr>
<td>70.0</td>
<td>13.67</td>
<td></td>
</tr>
<tr>
<td>80.0</td>
<td>14.41</td>
<td></td>
</tr>
<tr>
<td>90.0</td>
<td>13.59</td>
<td></td>
</tr>
<tr>
<td>100.0</td>
<td>13.97</td>
<td></td>
</tr>
<tr>
<td>110.0</td>
<td>13.72</td>
<td></td>
</tr>
</tbody>
</table>

To switch colorizing off, either select in the chart menu:

- Colors->No Color
Click on the No Color button \( \begin{array}{c}
\end{array} \) in the toolbar.

In addition in the Colors menu you will find different color schemes.

### 9.6 User sub-charts

User sub-charts are sub-charts that contain user entered, copied or calculated values. **User chart contents are saved when the log file is saved.**

#### 9.6.1 Creating a user sub-chart

To create a new user sub-chart manually,

Either select in the chart menu:

File\( \rightarrow \)New User Chart

Or use the keyboard shortcut Ctrl-N or click on the New User chart button \( \begin{array}{c}
\end{array} \) in the toolbar.

A dialog box will pop up that asks you what name to give this new user chart. Enter the name and click OK.

\[\text{USE ONLY NUMBERS AND LETTERS IN A SUB-CHART NAME. THE ONLY SPECIAL}
\text{CHARACTER ALLOWED IS THE UNDERLINE CHARACTER \_ . SPACES ARE NOT}
\text{ALLOWED. A SUB-CHART NAME MUST START WITH A LETTER.}\]

A new empty user chart will be created.

To change the sub-chart name, select it by clicking on its name in the chart tab area and select in the chart menu:

Table\( \rightarrow \)Change user chart name…

User charts can also be created by the Chart Calculator (see chapter xxx).

#### 9.6.2 Entering data in a user sub-chart

To enter data in a field in the user sub-chart, double click on a bin. The bin becomes editable and you can enter values manually.

#### 9.6.3 Deleting user chart entries

To delete a value, select it by clicking on it and hit the Delete key or use Edit\( \rightarrow \)Delete Selection
To delete a range of values, select them by clicking on the upper left corner of the range and dragging to the lower right corner (or vice versa). Then hit the **Delete** key.

### 9.6.4 Filling in user data quickly

To fill a range of bins quickly with a constant number, enter then value into one bin. Then:
- select the bin by clicking on it
- Use **Edit→Copy Selection** or keyboard shortcut **Ctrl-C** to copy the value on the clipboard.
- Select the range of bins to fill by clicking on the top left bin of the area and dragging to the bottom right bin of the area (or vice versa).
- Use **Edit→Paste Data** or keyboard shortcut **Ctrl-V** to paste the value.

### 9.6.5 Blending ranges

For user charts it is often desirable to fill a range of values in a column or row with a steadily rising or falling value.

To do that:
- Enter the beginning value in the bin where you want the range to start
- Enter the end value in the bin of at the end of the column or row range where you want the range to end
- Select the row or column range by clicking on the beginning bin and dragging to the just filled in end bin.
- Select **Edit→Blend Values**

**Example:**

<table>
<thead>
<tr>
<th>MAP (inHgVac)</th>
<th>RPM</th>
<th>Target_AFR</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.00</td>
<td>500</td>
<td>1000</td>
</tr>
<tr>
<td>2.50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5.00</td>
<td>14.70</td>
<td>14.70</td>
</tr>
</tbody>
</table>

Beginning value in the range is 14.7, end value is 11.0

After applying the blend:

<table>
<thead>
<tr>
<th>MAP (inHgVac)</th>
<th>RPM</th>
<th>Target_AFR</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.00</td>
<td>500</td>
<td>1000</td>
</tr>
<tr>
<td>2.50</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5.00</td>
<td>14.70</td>
<td>13.77</td>
</tr>
<tr>
<td>7.50</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The bins in between the beginning and end values are filled in with smoothly falling values.
9.7 Exchanging chart data with other programs

There are several ways in which chart data can be interchanged between LogWorks and other programs.

9.7.1 Exporting chart data

Select in the chart menu:

File->Export chart to .dif...

The entire chart, including all sub-charts, are saved in a .dif file. DIF files (Data Interchange Format) can be opened by many programs, including Excel.

9.7.2 Copying and pasting chart data

To copy the chart data to the clip-board, select the data by clicking and dragging.

Then select in the chart menu:

Edit->Copy Selection or use the keyboard shortcut Ctrl-C.

The chart data will be put on the computers clip-board as tab delimited text, which can be understood and pasted in by many programs.

To copy the entire current sub-chart, including the column and row headers, select:

Edit->Copy current view

You can paste data from other programs into user sub-charts, but not into the standard sub-charts. The other program must be capable of putting the data as tab-delimited text onto the clip-board, as most spreadsheets do anyway.

To paste the data in the user sub-chart, select the top-left bin of the area where you want to paste the data. Then select:

Edit->Paste Data or use the keyboard shortcut Ctrl-V.

The current view in the chart/graph pane must be a user sub-chart of course.

9.8 Overlaying charts

You can overlay one sub-chart over another so you can view both at the same time.

Select in the chart menu:

View->Overlay on current view->subchart name

To switch off overlays select:
**View->Overlay view Off**

An overlay view looks like this:

![Overlay view diagram](image)

The overlaid sub-chart is shown in the bins in *italic* and parenthesis ( ).
9.9 Viewing a sub-chart as 3D-graph

Select:

View->View as graph

or use the graph button in the toolbar.

The 3D chart window changes to look like this:

![3D Chart Window]

Or, if colorizing is switched on, it might look like this:
The 3D surface represents the content data of the currently selected sub-chart. The x and y axis are the independent channels, the content channel is the z-axis (vertical). The grid lines represent the spacing of the columns and rows. But the scales are equally spaced for easier readability. The graph view can be selected to be either surface, mesh or both (see Graphic menu). A mesh view looks like this:

In a mesh view, neighboring data points in the table are connected by black lines. But only neighbors above/below or left/right are connected, not diagonal neighbors. A surface only view (colorized) looks like this (without and with mesh):
The surface is constructed according to the following rules. If a data point has 2 or more neighbors (incl. diagonal) a triangle is drawn on the surface. Otherwise the data point is shown as 3D cross.
9.9.1 Manipulating the graph view

The graph is basically a 3D surface representing the dependency of the content channel from the x and y channels. The 3D surface (including the measurement grid and scales) is projected onto the chart/graph pane as if it were photographed by a camera. When changing the camera view the grids are always positioned such that they are ‘behind’ the surface or mesh as seen from the camera position. The scales are also moved to the edge of the grid that projects with the longest line on the pane so that the scale numbers overlap as little as possible.

You can manipulate the camera position and zoom with the following user actions:

a. Camera view angle
   Click on the graph with the left mouse button and move the mouse. Moving the mouse left and right rotates the camera around the graph left or right, but leaves the focal point (where the camera is pointed to) the same. Moving the mouse up and down rotates the camera vertically around the focal point.

b. Camera pan
   Hold down the Ctrl button while clicking and dragging the mouse. This moves the camera focal point and effectively moves the graph in the window.

c. Camera zoom
   Click on the graph with the right mouse button and move the mouse up and down. Moving the mouse up zooms in closer, moving the mouse down zooms away.

When the mouse is moved (without a mouse button pressed) over the graph, LogWorks effectively shoots a ray into the picture (like shooting a gun from the camera position). If that ray hits the graph, the closest bin-point is calculated and the values of all the sub-charts at that position are shown in the measurement pane.

If you get lost zooming and panning, the camera angle and zoom value can be reset at any time by selecting:

Graphic-->Reset Camera Position.

9.9.2 Glyphs

Glyphs are in computer visualization indicators of additional data drawn on a visualized view. LogWorks can show the Standard Deviation or the Min/Max points of each bin as glyphs. In the Graphic menu select Indicate Std. Dev. or Indicate Min/Max Values to show the glyphs for Std. Deviation or Min/Max. The glyphs are indicated as vertical lines emanating above and below a data point. The end-points of the lines indicate the Min or Max values or the deviation inside the bin from the average value.

NOTE: Glyphs can be added only when the current view shows the average values of the bins.

Here’s a view of a Min/Max glyphed surface:
9.9.3 Overlays on 3D graphs

Just as you can in the table view of the charts, you can overlay another sub-chart in the graph view as well. Select which sub-chart you to overlay want with:

View->Overlay on current view-->subchart name.

Overlays are shown in gray, half transparent as in this view:

Here the number of data points sub-chart is overlaid on the colorized average view. As the sessions included in this particular chart are mostly at WOT, most of the data points are located at the WOT line.
9.10 Calculations with charts

You can use the Math calculator built into LogWorks with charts as well. It is then called Chart Calculator. To call up the chart calculator select:

**Table->Chart Calculator...**

See section chapter xxx for details on how to use the calculators.

Calculation results can be stored in a user chart. If a user chart is created with the Chart calculator, it can be recalculated (for example if it’s source data changed) by selecting

**Table->Recalculate Math Charts**

Frequently used chart calculations can be stored in a chart calculator library. The library is a text file named **ChartMathlib.txt**. The library can be called up by selecting

**Table->Chart Calculator Library...**

Details on how to use the Math libraries can be found in chapter xxx

A simple very often used calculation is built into the charts function without using the calculator. When viewing one of the standard sub-charts, double-click on a bin. The following dialog box will show up:

This shows the current values of the clicked field. The target AFR or Lambda calculation functions are only available if the field content is AFR or Lambda. The fueling change calculation is based on fuel flow control where higher numbers represent more fuel.

The fueling factor is calculated by dividing the actual average AFR by the target AFR.
If for example your EFI is set by injector timing, just multiply the timing setting by the suggested number.

*This number is a suggested value only, different EFI systems will react differently.*

### 9.11 Realtime indication in the chart and graph (Map tracing)

If the chart is opened for a realtime log while recording, or while playing back a log, the current engine state (the bin it is running in) is indicated in the chart (table) view by highlighting the appropriate bin as in this:

![Chart Example](image)

Or as a ‘bouncing yellow ball’ in the 3D graph as in the example on the right.

⚠️ In the graph view the position of the ball shows the real current values the engine is running, not just the bin it is running in.

⚠️ Do not use the realtime view of the 3D graph unless your computer is at least a 800MHz Pentium II and has a graphics system with 3D acceleration. The 3D graph updates and warps in realtime as the data becomes available. The processing requirements for that are very intense.  
*This warning does not apply to tracing during playback.*

### 9.12 Some tips on working with charts

You have to be careful when using the chart for tuning the main fuel map of your EFI system. The chart reflects what’s in the log, including transition points and so on. So acceleration enrichment and possible warm-up enrichment are reflected in the averages as well. The best way to create a chart is to create an as long log as possible with steady load points. This way the effects of transitions are minimized. The fewer data points are represented, the less reliable the data. This is reflected as well in the standard deviation.
Acceleration runs in low gears are not ideal for calculating the load points. The same problem as in inertial dynos exists. The acceleration enrichment might still be active and reliable load point data can’t be extracted from only a few data points.
10 Math Trace Calculator

In the left window pane of the calculator you enter your calculations. The right side pane shows the results (incl. intermediate results) of that calculation.

You can cut and paste in the left window pane using the standard Window cut and paste shortcuts like Ctrl-X for cut, Ctrl-C for copy and Ctrl-V for paste. Right-clicking in the pane brings up a standard Window edit menu that can also be used for cut-n-paste.

With the Channel menu you can insert a channel name in the current cursor location without having to type in the name carefully and correctly.

NOTE:
Trace calculations can’t be executed in realtime, while recording.
10.1 Calculator basics

You can write formulas however you want to create new channels from existing data or calculate stuff.

There are certain rules you need to follow.

The following examples show how to use the Calculator: Formulas and calculations can be entered as described in the examples. By right-clicking in the formula window you can also cut and paste formulas in as text from any program.

Comments can be added in the calculation by putting a ‘#’ as the first character in a line.

Example 1: Calculate Force (in lb force) from car mass (lb) and acceleration (in g)

(Thanks, Isaac N.)

#m is vehicle weight in lb
m = 3000

#a is acceleration in g
a = 0.4
F = m * a

In this example acceleration a is 0.4 g and vehicle mass is 3000 lb. The result window shows the acceleration force. Enter the text (or copy it from this manual) and press the Calculate button

In the LogWorks Calculator, multiple variables used for a built-in function are separated by semicolons, not commas as is usual for most programming languages. Example:

avrg(a;b;c) calculates the average of the variable a, b and c.

The reason is that in some languages, German for example, a comma is used instead of the decimal point as is usual in English speaking countries. Using a semicolon allows stored calculations to be used in either case without re-writing. For every formula used, the math calculator converts numbers with decimals into the respectively used format before doing a calculation. So in English speaking countries, commas in the text will be converted into colons, or in countries that use decimal commas, colons are replaced by commas. Calculation formulas can so be interchanged internationally.

You can also change the formula so the user is asked for the car weight. To ask the user a question you put a question mark at the beginning of the line, followed by a space. Then type in the question, followed by an equal sign ‘=’ and then the name of the calculation variable you want to assign the answer to.
10.2 Asking for user data

Example 2: Calculate Force (in lb force) from car mass (lb) and acceleration (in g)

? Enter vehicle weight in lb = m
? Enter acceleration in g = a

\[ F = m \times a \]

When you press the calculate button here, a dialog box will pop up that allows the user to enter the values for his application.
If you want to suggest default values for a question, enter the default value in [ ] after the variable name in the question line as in this example:

? Enter vehicle weight in lb = m[3000]

The formula calculator libraries (see chapter 7) always store the last entered user values in the appropriate library entry so they don't have to be entered every time they are used.

Formula Calculator allows using as many intermediate results as you want to make the calculations clearer. The following example shows how.

Example 3: Calculate torque and horsepower from vehicle weight, acceleration, gear ratios, tire diameter and rpm

#m is vehicle weight in lb
m = 3000

#a is acceleration in g
a = 0.4
\[ F = m \times a \]

#dia is tire diameter in inches
dia = 25
\[ r = \frac{\text{dia}}{2\times12} \] #calculate radius in feet

#final (differential) ratio
finaldrive = 4.53

#gear ratio of the gear in which the acceleration is measured
gear_ratio = 0.82

#and finally rpm
rpm = 4500
\[ \text{torque} = F \times r \div (\text{gear\_ratio} \times \text{finaldrive}) \]
\[ \text{hp} = \text{torque} \times \text{rpm} \div 5252 \]

Or this time without fixed values, but a questionnaire that has to be filled out by the user.
? Enter vehicle weight in lb = m
? Enter acceleration in g = a

\[ F = m \times a \]

? Enter tire diameter in inches = dia

\[ r = \frac{\text{dia}}{2 \times 12} \]  #calculate radius in feet

? Enter final drive ratio = finaldrive
? Enter gear ratio = gear_ratio
? Enter rpm = rpm

\[ \text{torque} = F \times r / (\text{gear\_ratio} \times \text{finaldrive}) \]
\[ \text{hp} = \text{torque} \times \text{rpm} / 5252 \]

LogWorks collects up to 10 questions into a questionnaire dialog box, so that only a minimum of dialog boxes pop up. If more than 10 questions are asked, the questions are asked with multiple sequential dialog boxes of 10 questions each.

### 10.3 Restrictions on variable names

There are certain restrictions on variable names so that the Formula Calculator can correctly distinguish between what is an operator like + - * / and a variable or constant.

1. Variable names **MUST** start with a letter, not a number or special character.
2. Variable names **CAN ONLY** contain letters and numbers, no special characters, with one exception.
3. The underline character _ is allowed.

### 10.4 Using LogWorks channels

Suppose you don't want to enter the values manually, but use data collected in a LogWorks channel. You can use LogWorks channels as variables just as if you had defined them.

For a simple calculation with only one value as above, the formula calculator chooses the value to use according to the following rules:

If an area in the visible window is selected, get the first selected data point in the window (from left to right).
Otherwise choose the first selected data point in the session
If nothing is selected, use the first (leftmost) data point in the visible window.

**Example 4: Calculate torque and horsepower from vehicle weight, acceleration channel, gear ratios, tire diameter and rpm**

? Enter vehicle weight in lb = m
\[ F = m \times \text{ACCEL} \]
#ACCEL is the acceleration channel from the LMA-3

? Enter tire diameter in inches = dia
\[ r = \frac{\text{dia}}{2 \times 12} \] #calculate radius in feet

? Enter final drive ratio = finaldrive
? Enter gear ratio = gear_ratio
? Enter rpm = rpm

\[ \text{torque} = F \times r / (\text{gear\_ratio} \times \text{finaldrive}) \]
\[ \text{hp} = \text{torque} \times \text{rpm} / 5252 \]

If the channel name is not known initially because the user might have assigned a different name to it, you can ask for the acceleration channel as in this example:

?i Enter your acceleration channel name = a

The Formula Calculator knows from the i following the question mark that a channel name is requested, not a number.

⚠️ You can also use bit channels. Bit channels for calculation purposes have only two values: 0 and 1 meaning on and off, high or low and so on.
10.5 Calculating new LogWorks channels

The restrictions on variable names also apply to channel names used in the calculations. These restrictions are imposed specifically to allow calculations because the math calculator cannot distinguish between for example a channel name “5+mychannel” and the command to add 5 to the channel “mychannel”. Same is true for example for “mychannel-5” or subtracting 5 from the channel “mychannel”.

10.5.1 Creating calculated value channels

Suppose you want to create a new channel from existing data. This channel can be used then just like any other channel in LogWorks. The LogWorks 3 restriction of 64 value channels and 32 bit channels includes calculated channels.

Example 5: Calculate torque and horsepower channels from vehicle weight, acceleration channel, gear ratios, tire diameter and rpm channel

? Enter vehicle weight in lb = m
F = m * ACCEL  #ACCEL is the acceleration channel from the LMA-3

? Enter tire diameter in inches = dia
r = dia/(2*12) #calculate radius in feet

? Enter final drive ratio = finaldrive
? Enter gear ratio = gear_ratio

\[ \text{trq} = F \times r \div (\text{gear}_\text{ratio} \times \text{finaldrive}) \]

\[ \text{MC(} \text{power;} \text{hp)} = \text{trq} \times \text{RPM} \div 5252 \#\text{RPM is the RPM channel} \]

MC( ) indicates that a new value channel is to be created (Make Channel). The first word after the parenthesis (‘power’ in the example) is the name of the new channel. The second word, separated from the first by a semicolon, is the unit assigned to the channel.

The format of the MC command is:

\[ \text{MC(channel}_\text{name;} \text{channel}_\text{unit;} \text{minimum}_\text{bound;} \text{maximum}_\text{bound)} \]

The channel unit, minimum_bound and maximum_bound are optional. See below.

LogWorks value channels have ‘bounds’. The bounds are there to limit what is shown on the main session window to the interesting region. Input channels are naturally bounded by the input capability of the data collection devices, typically 0..5V. Calculated channels have no such natural limits. When no bounds are specified, the MC command calculates the minimum and maximum of the bounds automatically by looking at the minimum and maximum of the calculated trace in all sessions. This can lead to too large a range because calculations are always performed on all sessions in a log.
To limit the min and max bounds select the areas in each session you are interested in calculating. When areas are selected, the formula calculator will only use the selected areas for the bounds calculations.

You can also set fixed bounds by adding the bounds to the MC command like this:

```
MC(power; hp; 0; 500) = trq * RPM / 5252 #RPM is the RPM channel
```

This will now create a channel with bounds of minimum 0 hp and maximum 500 hp. This eliminates for example negative hp values created during braking.

If you want to set the minimum bound only, just leave out the maximum as in this:

```
MC(power; hp; 0) = trq * RPM / 5252 #RPM is the RPM channel
```

If you want to set the maximum bound only, just leave out the minimum, but use 2 semicolons as in this:

```
MC(power; hp;; 500) = trq * RPM / 5252 #RPM is the RPM channel
```

---

LogWorks stores the data in 10 bit words. This means that the results are stored with a resolution of about 0.1%. Therefore calculated channels should not be used in further calculations. Calculate one channel at a time.

For example:

```
MC(trq; lbft) = F * r / (gear_ratio * finaldrive)
MC(power; hp) = trq * RPM / 5252 #RPM is the RPM channel
```

Would work, but can create wrong results because trq is stored with 10 bit resolution and then used in the hp calculation.

Instead recalculate or assign the torque channel as in this:

```
trq = F * r / (gear_ratio * finaldrive)
MC(torque; lbft) = trq
MC(power; hp) = trq * RPM / 5252 #RPM is the RPM channel
```

---

### 10.5.2 Calculating new bit channels

Bit channels can be calculated the same way as value channels. If the calculation result is 0 or false, the resulting bit channel value is 0. If the result is not zero, the resulting bit channel value is 1. You can also use Boolean operations in bit channels.
To distinguish between creating bit channels and value channels, use MB instead of MC. MB stands for make bit channel.

For example:

\[ MB(\text{RPMLimit}) = (\text{RPM} > 6500) \]

Would create a bit channel that is on (1 or true) whenever RPM is bigger than 6500.

The format for the MB command is:

\[ MB(\text{channel name}) \]

No unit or bounds need to be specified because bit channels have no unit and range.
10.6 Dealing with units

Sometimes a channel used for a calculation is in a different unit as required for the calculation. For example if the user set ft/sec^2 as acceleration metric, but the calculation requires g’s. You can force an automatic unit conversion by using the unit converter operator.

Example 6: Automatic unit conversions

? Enter vehicle weight in lb = m

\[ F = m \times ACCEL\{g\} \]

The curly braces \( \{ \) around the desired unit after a channel name recalculates that channel temporarily to the new unit. Once a channel is converted, you can’t convert it again in the same calculation. The converted channel will be used for the rest of the calculation and further \( \{ \)’s after a channel name will be ignored.

If a question for a channel name is asked from the user, the automatic unit conversion can also be invoked to make sure the channel is in the correct units for the calculation.

?i Enter your acceleration channel = a\{g\}

This recalculates the acceleration channel into gs temporarily.

If the unit conversion requested is unknown to LogWorks, a dialog box will pop up that asks how to convert the unit:

Image: Unknown Conversion Target

The formula uses ‘ou’ as placeholder for the original unit.

Enter the formula and the calculation will proceed.

For details on the unit conversion, see chapter 8 How LogWorks unit conversions work.
10.7 Formula Calculator Functions

Rules:
- If a function uses multiple arguments, like floor(x;10), the arguments are separated by semicolons.

The Formula Calculator has the following built-in functions, operators, constants and values.

Pre-assigned constants and values
- e 2.71828182846
- pi 3.14159265359
- t time in seconds from begin of session

Math Operators
- + Addition
- - Subtraction
- * Multiplication
- / Division
- ^ Power of, as in x^2 would square x

Boolean Operators
- Boolean operations result in just one of 2 possible results: 1 or 0, equivalent to true or false.
- The following Boolean operators are built into the Math Calculator:
  - & AND, as in a & b. Result is 1 if both, a and b, are 1.
  - | OR, as in a | b. Result is 1 if either a or b are 1.
  - ! NOT as in !a. Result is 0 if a is not 0. Result is 1 of a is 0.
  - == EQUAL as in a == b. Result is 1 if a is equal to b. Otherwise result is 0.
  - != UNEQUAL as in a != b. Result is 0 if a is equal to b. Otherwise result is 1.
  - > GREATER THAN as in a > b. Result is 1 if a is bigger than b.
  - < SMALLER THAN as in a < b. Result is 1 if a is smaller than b.
  - >= GREATER OR EQUAL as in a >= b. Result is 1 if a is bigger or equal to b.
  - <= SMALLER OR EQUAL as in a <= b. Result is 1 if a is smaller or equal to b.

Regular Math Functions
- abs Calculates absolute value (-x turns into x)
- acos Calculates arc-cosine as in acos(x)
- asin Calculates arc-sine as in asin(x)
- atan Calculates arc-tan as in atan(x)
- avrg Calculates the average of multiple values as in avrg(a;b;c;d)
- ceil Limits value to a maximum as in ceil(x; 10) would limit x to a maximum of 10
- cos Calculates cosine as in cos(x)
- cosh Calculates hyperbolic cosine as in cosh(x)
- fact Calculates the factorial of x as in fact(x) calculated as x*(x-1)*(x-2)*...(x-x+1)
- floor Limits value to a minimum as in floor(x; 2) would limit x to a minimum of 2
- max Returns the largest of a set of variables as in max(a;b;c;d)
min Returns the smallest of a set of variables as in \textit{min(a;b;c;d)}
ln Calculates the natural logarithm (base e) of x as in \textit{ln(x)}
log10 Calculates the base 10 logarithm of x as in \textit{log10(x)}
sin Calculates sine as in \textit{sin(x)}
sinh Calculates hyperbolic sine as in \textit{sinh(x)}
sqrt Calculates square root as in \textit{sqrt(x)}
sum Calculates the sum of multiple values as in \textit{sum(a;b;c;d)}
tan Calculates tan as in \textit{tan(x)}
tanh Calculates hyperbolic tan as in \textit{tanh(x)}

Note:
\textit{Trigonometric functions (sin, cos...) use radians arguments, not degrees.}

Special channel functions

slope Calculates the slope (or differential) of a channel as in \textit{slope(channel)}.

area Calculates area under the channel curve or partial integral (or area) as in \textit{area(channel; t0; t1)} where t0 and t1 are constants in seconds in the session. Can also be used as in \textit{area(channel; t-10; t+10)} to calculate running area (integral).

Note1:
The slope functions will only take a channel name as argument, not an evaluated function as in \textit{slope(channel * x + y)}.

The automatic unit conversion operator can be applied though.

Note2:
Slope calculations are very sensitive to noise on the channel. To minimize noise it is better to smooth the channel before applying the calculations. As a rule, smoothing of 0.25 to 1 second is enough in most cases (reasonably smooth data to begin with). Experiment with the right smoothing value for your application.
10.8 Chart Calculator

The chart calculator usage is exactly the same as for the Math Trace Calculator. With the following differences:

- Channel names CANNOT be used as variables
- Sub-chart names can be used as variables.
- The special math functions slope and area cannot be used.
- The MC special function stands here for “Make Chart”.
  The additional variables for the MC function, like unit and limits, are ignored. MC creates a new user chart.
- The ‘t’ variable for time is not available
- Standard sub-charts can be modified

Because sub-chart names can be used as variables, the same restrictions as for general variable names applies here too. See section 5.3, Restrictions on variable names for details.

10.8.1 Pre-assigned names for the standard sub-charts:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>chart_avrg</td>
<td>The “average value” sub-chart.</td>
</tr>
<tr>
<td>chart_num</td>
<td>The “number of datapoints” sub-chart</td>
</tr>
<tr>
<td>chart_stddev</td>
<td>The “standard deviation” sub-chart</td>
</tr>
<tr>
<td>chart_min</td>
<td>The “minimum value” sub-chart</td>
</tr>
<tr>
<td>chart_max</td>
<td>The “maximum value” sub-chart</td>
</tr>
<tr>
<td>chart_X</td>
<td>The horizontal value (column header) of the bin used</td>
</tr>
<tr>
<td>chart_Y</td>
<td>The vertical value (row header) of the bin used</td>
</tr>
</tbody>
</table>

10.8.2 Using the Chart Calculator

Here are a few examples on how to use the chart calculator:

Example 1: Filtering the chart so that only values with more than 50 data points are used:

\[
\text{chart\_num} = (\text{chart\_num} > 50) * \text{chart\_num}
\]

In this case, the number of data points is reset to 0 (empty) if it has less than 51 data points in it. The term \((\text{chart\_num} > 50)\) evaluates to 1 if the number of data points in the bin is more than 50, otherwise to 0. So, chart\_num stays either the same \((\text{chart\_num} \times 1 = \text{chart\_num})\) or becomes 0 \((\text{chart\_num} \times 0 = 0)\).
Example 2: Calculating a horsepower sub-chart from a chart containing torque:

For this example the chart_average view contains the engine torque in lbft, the column headers (horizontal axis of the chart) are in RPM.

\[ MC(\text{power}) = \text{chart\_avrg} \times \text{chart\_X} / 5252 \]

Example 3: Calculate a new fuel map based on an existing fuel map sub-chart and a target AFR sub chart:

Requirements:

a. The chart_average view contains the measured AFR over RPM and MAP/MAF or Throttle position.
b. There is a sub-chart named current_map that contains the current fuel map
c. There is a sub_chart named target_afr that contains the target AFRs for each bin
d. The fuel map is linearly related to the injector duty cycle, where 0 means no fuel and some max value means 100% injector duty cycle.

\[ MC(\text{new\_map}) = \text{current\_map} \times \text{chart\_avrg} / \text{target\_afr} \]
11 LogWorks Libraries

LogWorks has multiple libraries. These libraries are used to store frequently used searches or calculations. When using the LogWorks Log Window, the Trace Libraries or the search Library is used. When using the 3D chart, the Chart Library is used.

Each library entry or formula has a name under which it can be easily identified, and (optionally) a category to which it belongs to further simplify and find calculations or searches.

So that distracting duplicate entries are avoided, the Trace Library is divided into two parts. One part is in US units, the other in international units. You select which Library is used by selecting the appropriate Preferences in the LogWorks Main Window menu.

Libraries are plain text files. So they can be opened and edited by any text editing program, even the simple Notepad program built into Window. In practice, this is rarely necessary because the Library editor built into LogWorks can accomplish all Library management tasks. For details on the file format of Library text files, see chapter 7.4 Library formats.

The library files must be in the same folder as the LogWorks.exe program for LogWorks to find them.

11.1 Using the Libraries

11.1.1 Basic usage

Log Window:
Select Formula Collection… in the Tools menu for trace calculations.
Select Search Library… in the Edit menu for frequently used searches.

3D chart window:
Select Chart Calculator Library… in the Table menu for chart calculations.

The following dialog box will appear:
With the uppermost field, you can select or edit the category the calculation belongs to. In the middle field you select or edit the formula name. The lowest field shows and allows you to edit a short description of the formula.

To delete the formula from the library, click on the `Delete Formula` button. To save possible changes you made to the name, category or description, click on the `Save Changes` button.

To change the formula itself, click on the `Edit Formula` button. The Trace Calculator dialog box will show up and allow you to change the formula.

To execute the selected formula, click on the `Use Formula` button.

**Note:**
*When entering user values in a formula during use, the entered values are stored in the library as defaults, so that they don’t have to be entered every time the formula is used.*

For a tuner that tunes multiple cars it would be of advantage to copy the libraries to a different (customer specific) folder as the libraries contain the last default values. Then copy the libraries to the LogWorks Folder when the customer car is retuned. This way the customer’s last calculation values are restored as defaults.

### 11.1.2 Adding a new formula to a library

If you entered a new formula in either the Trace calculator, Chart calculator or Auto-search window, you can make it a new library entry by clicking the Add to Library button in the calculator or search window. The same dialog box as above will show up. Enter the name of the new formula in the middle field. Enter a short description in the bottom field. Select a category or enter a new one in the uppermost field.
11.2 LogWorks built-in Trace calculations

These are the calculations built into LogWorks for calculating new channels or traces. Check on the Innovate Motorsports web site (www.Innovatemotorsports.com) for additional calculations as they become available.

To understand the calculations a few things must be known by the user:

b. Every calculation is only as good as the data used as basis for the calculation. This is especially true for horsepower and torque calculations.

c. Many time based calculations are based on an engine cycle. A 4-stroke engine cycle requires 2 engine revolutions.

11.2.1 Category: Fuel Calculations

Fuel flow (lb/hr) from duty cycle (US) or (cc/min) for International

Requires you to enter the specs of the injectors used (lb/hr) or (cc/min), their rated pressure in PSI (US) or kPa (int.), the injector duty cycle channel name (easy if you have an LMA-3), the fuel pressure the regulator is set to, and the total number of injectors. Creates a fuel flow channel in lb/hr or cc/min total for the engine.

Note: Specifying injectors in lb/hr is actually a misleading metric. Injectors flow a certain volume in a specified time. Because most fuels have very similar viscosity, but very different specific mass, an injector rated for example for 10 lb/hr will flow 10lb per hour of the test gasoline, but a very different number of lbs for example for methanol.

11.2.2 Density and VE

Intake air density

Calculates an air density channel in lb/cuft (US) or kg/m^3 (Internat.) from intake air temperature and absolute intake air pressure (MAP) channels.

11.2.3 Power calculations

These calculations result in two channels, one for torque and one for power. The US version of the calculations result in a torque channel in lbft and a horsepower channel in hp. The International versions result in a torque channel in Nm and a power channel in kW. You can easily change the formulas to get the results in the units you want. Because these calculations are based on the acceleration of the vehicle, the speed of the vehicle must be known. It is assumed the test runs are done in a single gear (3rd gear for example). Because vehicle speed is calculated from gear ratios and tire diameter, the calculations will be unreliable for an automatic transmission vehicle below the converter lockup rpms. They will be correct at rpm levels above converter lockup. Because a vehicle does not accelerate any more at top speed, for calculations based solely on acceleration alone, the torque (and therefore horsepower) would be zero there. That’s of course not the case. The calculations therefore also require to put in the frontal area and Cd value of the car to calculate aerodynamic resistance force. As this force is speed dependent.
and acts against the acceleration force, it must be accounted for. The frontal area and Cd value for many cars can be found here:

http://www.mayfco.com/tbls.htm

The resulting values are corrected for different meteorological conditions as well as using standard SAE correction.

To use the power calculations correctly, use the selection tool to select ONLY the areas of full throttle at the correct gear.

The results should not be relied upon in the areas at the edges of the selected areas. Rounding of the signal by smoothing will affect the calculated results at about 1 second from the edges if a smooth value of 1 second is used. Smoothing is required for calculations involving slopes because slope calculations will vastly exaggerate any noise or digitizing artifacts in the signal. These artifacts show up as oscillations on top of the calculated channel.

The required data to be entered must be as accurate as possible. The vehicle weight entered is the weight as tested, incl. fuel, liquids and driver, not the dry weight. The aerodynamic force calculations are based on dry air. The published numbers by the manufacturers might be on the low side of actual, even for an unmodified vehicle. Addition of aerodynamic devices like wings, splitters, side-skirts and so on can drastically change the cd-value and frontal area. The same is true for wider tires, lowering and so on.

NOTE:
These calculations should be used to compare the results of modifications made to fueling and/or timing and their relative effects on power and torque. They are NOT intended as replacement for dyno time if the actual power and torque numbers are needed.

Torque/power from Accel/RPM

This calculation uses primarily the acceleration channel from the LMA-3 and RPM to calculate torque and power. It also uses the tire diameter and gear ratios to calculate speed for the aerodynamic force calculations.

Torque/Power from speed and acceleration signal

This calculation uses a speed signal input and acceleration signal from the LMA-3 to calculate torque and power.
11.3 LogWorks built-in chart calculations

These are the calculations built into LogWorks for calculating with charts. Check on the Innovate Motorsports web site (www.Innovatemotorsports.com) for additional calculations as they become available.

11.3.1 Fueling calculations

Fuel map from measured AFR and target AFR

Requires a current fuel map as input chart (user sub-chart) and a target AFR sub-chart. The current fuel map values are assumed to increase linearly with injector timing, where 0 means no injection (injector cut off).

11.4 Library file format

If you feel the need to edit the libraries directly with a text editor, this section shows the file format. All libraries have the same basic format. Irrespective if it is a chart library, trace library or search library.

The library managers use special comments in the formulas to identify individual formula entries. These special library comments use a double comment marker (##) at the beginning of a text line, followed by the text.

11.4.1 Name comment

Format:

##Nformulaname

The comment starts with ##N, followed immediately by the name of the formula. This is a required comment. The Library managers identify formulas as the text between formula name comments. This means a formula entry starts with the formula name and ends at the beginning of the next formula name or the end of the text file.

11.4.2 Category comment

Format:

##Cformulacategory

This comment is optional and, if used, follows the Name comment. The comment starts with ##C, followed immediately by the category used for the formula.
11.4.3 Description comment

Format:

##[
Multiple lines of comment text
##]

This comment is optional and, if used, follows the category comment. If no category comment is used, it follows the name comment. The library manager strips out any text between the ##[ and ##] description markers before handing a formula to the calculator.
12 LogWorks Plug-ins
13 How LogWorks unit conversions work

To automatically convert units, LogWorks uses a special library file named Conversions.txt. This file must be located in the same folder as the LogWorks.exe file. You can manually extend the number of conversions LogWorks understands by editing this file.

Additional conversions for many units can be found here:
www.onlineconversion.com

**NOTE:**
*Avoid multiple conversions back and forth. A computer has a limited resolution for numbers which creates rounding effects, and these rounding effects add up after a few conversions and will create inaccurate data.*

13.1 Conventions on unit names

For LogWorks to understand a conversion, certain conventions must be followed:

13.1.1 Temperature conventions

Temperature measurements are in degrees Celsius, degrees Fahrenheit or degrees Kelvin.

- Celsius units are named **degC**
- Fahrenheit units are named **degF**
- Kelvin units are named **degK**

13.1.2 Pressure conventions

Pressures used in engine diagnostics are either in gauge pressure or absolute pressure.

Gauge pressure is typically what a boost or vacuum gauge measures. It is actually the pressure difference to the current atmospheric pressure, not the actual pressure itself.

Absolute pressure is the pressure above absolute vacuum. This is what most MAP sensors measure. MAP stands for **Manifold Absolute Pressure**, not Manifold Air Pressure as a lot of people think.

The fueling or AFR value of an engine is a measure of the ratio of the mass of air entering the engine divided by the mass of fuel. The mass of fuel, being a liquid, changes little with pressure or temperature. Air, being a gas, changes dramatically. Doubling the absolute pressure with no change in temperature, will double the mass of air entering and therefore would also require double the fuel for the same AFR. The air mass is dependent on ABSOLUTE pressure in the manifold, not gauge pressure and is also dependent on temperature.

Pressures are mainly measured in PSI (US, pounds-per-square-inch) or kPa (international, kilo-Pascal). The kPa value is by convention an absolute pressure value.

To distinguish between gauge pressure and absolute pressure it is common to add a ‘g’ at the end of a gauge pressure unit and an ‘a’ at the end of an absolute pressure unit. If the ‘a’ is
omitted, absolute pressure is assumed. Sometimes also a ‘vacc’ is added instead of a ‘g’ to denote a vacuum measurement. This is typically used for carburetor tuning and is done in the US as inches of vacuum. This is a gauge pressure unit and indicates again the pressure difference to atmospheric pressure. InHgVacc is a typical unit for vacuum measure. It means how high (in inches) the given vacuum could suck up a column of mercury (chem. sign Hg). In reality the mercury is not sucked up, but pushed up by atmospheric pressure. Another vacuum measurement unit is mmHg. It’s the same as lnHg, but expressed in millimeters, not inches.

When converting between absolute pressure units and gauge pressure units the LogWorks built-in unit calculator will ask you for the current atmospheric pressure. You can enter the atmospheric pressure either in millibar or inches of mercury. Any barometer or weather station/radio will give you the atmospheric pressure in one of those two units. LogWorks will store the entered value in memory.

13.2 The Conversions.txt format

You can add comments in the file by preceding a line of text with a #.
All text in the line behind the # is ignored by the unit calculator.

To reduce the number of conversion formulas required, LogWorks uses a two-step approach to the conversions.

First the source unit (the one you are starting out with) is converted into a master unit. You can use any unit as master unit, but make sure all units of the same family are using the same master unit. For example for pressure the master unit is kPa. A unit family is a group of units measuring the same quantity, like pressure or temperature.

In the second step the converted value (converted to the master unit) is converted to the target unit (the one you want to convert to).

Example to convert PSI (absolute) into bar (absolute):

PSIa (absolute pressure in PSI) is converted first into kPa. Then the kPa value is converted to bar.

In the formulas for the conversion the name ‘ou’ stands for original unit.

A typical example for is the conversion formula for converting PSIa to kPa:

\[ PSIa > kPa = ou \times 6.8947573 \]

This means to LogWorks:

To convert PSIa to kPa, multiply the original unit (PSIa) by 6.8947573

Another pre-programmed variable name used by the unit calculator is ATMP. ATMP stands for atmospheric pressure. Internally LogWorks stores the current atmospheric pressure in kPa. When you enter the current atmospheric pressure, LogWorks decides what unit (inHg or millibar) was used by looking at the number. If the number is above 100, it’s in millibar, otherwise its inHg. It then converts that number to kPa for internal storage. Initially, when LogWorks starts up, the value of ATMP is 0. As air-breathing internal combustion engines are rarely used in space, LogWorks knows to ask when the current ATMP is required, but its current value is equivalent to the air pressure in intergalactic space (zero).
Here’s the complete pressure unit family as stored in the Conversions.txt file:

\[
\begin{align*}
\text{PSI} > \text{kPa} & = \text{ou} \times 6.8947573 \\
\text{PSIa} > \text{kPa} & = \text{ou} \times 6.8947573 \\
\text{PSIg} > \text{kPa} & = (\text{ou} \times 6.8947573) + \text{ATMP} \\
\text{kg/cm}^2 > \text{kPa} & = \text{ou} \times 98.06665 \\
\text{bar} > \text{kPa} & = \text{ou} \times 100 \\
\text{inHga} > \text{kPa} & = \text{ou} \times 3.3863887 \\
\text{inHgVac} > \text{kPa} & = \text{ATMP} - (\text{ou} \times 3.3863887) \\
\text{millibar} > \text{kPa} & = \text{ou} \times 0.1 \\
\text{mb} > \text{kPa} & = \text{ou} \times 0.1 \\
\text{kPa} > \text{PSI} & = \text{ou} / 6.8947573 \\
\text{kPa} > \text{PSIa} & = \text{ou} / 6.8947573 \\
\text{kPa} > \text{PSIg} & = (\text{ou} - \text{ATMP}) / 6.8947573 \\
\text{kPa} > \text{kg/cm}^2 & = \text{ou} / 98.06665 \\
\text{kPa} > \text{bar} & = \text{ou} / 100 \\
\text{kPa} > \text{inHga} & = \text{ou} / 3.3863887 \\
\text{kPa} > \text{inHgVac} & = (\text{ATMP} - \text{ou}) / 3.3863887 \\
\text{kPa} > \text{millibar} & = \text{ou} \times 10 \\
\text{kPa} > \text{mb} & = \text{ou} \times 10
\end{align*}
\]

As you can see, the first half of the conversions all convert a source unit to kPa. The second half of the conversions convert kPa to another target unit.

The following master units are used in the Conversions.txt file:

- **Temperatures in degree Kelvin (degK)**
- **Pressures in kiloPascal (kPa)**
- **Acceleration in g**
- **Speed in meters per second (m/sec)**
- **Weight (mass) in kilograms (kg)**
- **Length in meters (m)**
- **Volumes in liters (l)**
- **Power in kiloWatt (kW)**
- **Torque in Newton-meters (Nm)**
- **Frequency in Hertz (Hz)**
- **Density in kilograms per cubic meter (kg/m^3)**
14  Tips & Tricks for using LogWorks

The included log file example Autobahn.log shows a good example of using the features of LogWorks to determine if a fueling change made a difference in power of the engine.

Let's look at Session 1 and Session 3 in the example. Both are 3rd or 4th gear pulls from low RPM to redline. We look at the run from 1300 RPM to 8400 RPM.

Session 1. Time between 1300 RPM and 8400 RPM is 28.18 sec

Session 3. Time between 1300 RPM and 8400 RPM is 27.93 sec

Now we are using the overlay tool to overlay session 3 over session 1:
What is immediately noticeable is that the AFRs of session 3 are higher than those of session 1 in the area below 7000 RPM, but lower above. Let's see how that affects power and acceleration. Acceleration can be determined by the slope of the RPM curve. The steeper the slope, the higher the acceleration and therefore power (assuming other conditions like weight and wind are the same).

In area 1, acceleration is slightly lower in session 3, while AFRs are higher than in session 1. In area 2, both RPM slopes match. Therefore the AFR change had little effect. In area 3, the RPM slope of session 3 is noticeably steeper. The engine made more power with the leaner AFR. In area 4, the RPM slope of session 3 is flatter. The engine made less power, but AFRs are richer than in that area.

You can also see than when you compare the WOT rows in the charts of the session

### Session 1

<table>
<thead>
<tr>
<th>Throttle (%)</th>
<th>RPM</th>
<th>AFR</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>1500</td>
<td>13.4</td>
</tr>
<tr>
<td></td>
<td>2000</td>
<td>13.1</td>
</tr>
<tr>
<td></td>
<td>2500</td>
<td>13.1</td>
</tr>
<tr>
<td></td>
<td>3000</td>
<td>13.0</td>
</tr>
<tr>
<td></td>
<td>3500</td>
<td>12.9</td>
</tr>
<tr>
<td></td>
<td>4000</td>
<td>13.0</td>
</tr>
<tr>
<td></td>
<td>4500</td>
<td>12.9</td>
</tr>
<tr>
<td></td>
<td>5000</td>
<td>13.0</td>
</tr>
<tr>
<td></td>
<td>5500</td>
<td>12.7</td>
</tr>
<tr>
<td></td>
<td>6000</td>
<td>12.6</td>
</tr>
<tr>
<td></td>
<td>6500</td>
<td>12.4</td>
</tr>
<tr>
<td></td>
<td>7000</td>
<td>12.3</td>
</tr>
<tr>
<td></td>
<td>7500</td>
<td>12.4</td>
</tr>
<tr>
<td></td>
<td>8000</td>
<td>12.3</td>
</tr>
<tr>
<td></td>
<td>8500</td>
<td>12.3</td>
</tr>
</tbody>
</table>

### Session 3

<table>
<thead>
<tr>
<th>Throttle (%)</th>
<th>RPM</th>
<th>AFR</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>1500</td>
<td>14.7</td>
</tr>
<tr>
<td></td>
<td>2000</td>
<td>14.3</td>
</tr>
<tr>
<td></td>
<td>2500</td>
<td>14.0</td>
</tr>
<tr>
<td></td>
<td>3000</td>
<td>14.0</td>
</tr>
<tr>
<td></td>
<td>3500</td>
<td>14.1</td>
</tr>
<tr>
<td></td>
<td>4000</td>
<td>13.7</td>
</tr>
<tr>
<td></td>
<td>4500</td>
<td>13.5</td>
</tr>
<tr>
<td></td>
<td>5000</td>
<td>13.3</td>
</tr>
<tr>
<td></td>
<td>5500</td>
<td>13.1</td>
</tr>
<tr>
<td></td>
<td>6000</td>
<td>12.9</td>
</tr>
<tr>
<td></td>
<td>6500</td>
<td>12.4</td>
</tr>
<tr>
<td></td>
<td>7000</td>
<td>12.1</td>
</tr>
<tr>
<td></td>
<td>7500</td>
<td>12.0</td>
</tr>
<tr>
<td></td>
<td>8000</td>
<td>12.0</td>
</tr>
<tr>
<td></td>
<td>8500</td>
<td>12.0</td>
</tr>
</tbody>
</table>

You can see that the power curve can be improved by richening up the fields below ~4500 RPM and leaned out in the fields at 7000 RPM and above.
This can be even better analyzed when using the Math Trace Calculator Library and the X-Y Plot function. For this example all the WOT runs in Session 1..4 in the example file are selected. The RPM trace is smoothed in those sessions to 1.06 seconds. Then, using the Math library, torque and horsepower are calculated from gear ratios, tire diameter, cars frontal area, weight and aerodynamic coefficient, and the RPM slope. The run in Session 3 is overlaid on session one, and torque, power and AFR together are shown on the X-Y plot:

Again, one can see that at the leaner AFR of the overlaid session the torques are higher, except at the low RPMs below about 4500. From about 7000 RPM on the overlay torque curve is lower because the AFR's are richer than in the original session.

Creating a 3D chart of the torque vs. AFR and RPM dependency for the selected WOT areas shows what optimum AFR should be used for max power. This chart is created from only 4 runs (Session 1..4) but illustrates how LogWorks can be used for optimization. More runs will refine the results.
This shows maximum torque is reached at 5000 RPM and 13.33 AFR.

Here’s the same chart as a 3D surface:

One can clearly see the trend to a torque peak (1) at about 13.3 – 13.4 AFR for this particular engine at that engine’s current timing settings. A secondary peak exists at a different RPM at (2). The key to good tuning of course is to arrive at the maximum torque achievable without engine knock by varying both, timing and fueling.
15 Interfacing with various sensors

15.1 Electronic parts basics

15.1.1 Diodes

Diodes let current pass in one direction (Anode (A) to Cathode (K)) and block current in the other direction. The exception are Zener diodes. They work like regular diodes, but in the reverse direction they will pass current only when the voltage is bigger or equal to the ‘Zener’ voltage. This has the effect of limiting the voltage over the Zener diode to the zener voltage. On a typical diode the Cathode is marked with a ring as in this picture:

![Diode Symbol](image)

15.1.2 IC’s

Typical IC’s are either surface mount or through-hole. Through-hole ICs are easiest to use. A typical picture of a 16 pin and 14 pin through-hole IC (DIP) are shown below:

![IC Pictorial](image)

Pin-Number counting starts to the left of the mark and proceeds counter-clock-wise around the chip.

15.1.3 Resistors

Resistors come in many different values and also different tolerance grades and maximum wattage. Typical tolerance grades are 10%, 5% and 1% with 5% being the most common. Wattage ratings are 1W or bigger, 1/2W, 1/4W, 1/8W, and so on. The minimum required wattage rating can be calculated with:

\[ V^2 / R \]

Where V is the max voltage the resistor will see, and R is the resistance in Ohms.

The resistance value and tolerance grade on a typical resistor is marked as colored rings (typically 4). The first ring being close to one of the connection leads. The first two rings determine the first two digits of the resistance value. The third ring determines the number of 0's to add to the first two digits to get the total value in Ohms.
<table>
<thead>
<tr>
<th>Color</th>
<th>Ring1,2 value</th>
<th>Ring 3 zero's</th>
<th>Color</th>
<th>Ring1,2 value</th>
<th>Ring 3 zeros</th>
</tr>
</thead>
<tbody>
<tr>
<td>Black</td>
<td>0</td>
<td>none</td>
<td>green</td>
<td>5</td>
<td>00 000</td>
</tr>
<tr>
<td>Brown</td>
<td>1</td>
<td>0</td>
<td>blue</td>
<td>6</td>
<td>000 000</td>
</tr>
<tr>
<td>Red</td>
<td>2</td>
<td>00</td>
<td>purple</td>
<td>7</td>
<td>0 000 000</td>
</tr>
<tr>
<td>Orange</td>
<td>3</td>
<td>000</td>
<td>gray</td>
<td>8</td>
<td>0 000 000</td>
</tr>
<tr>
<td>Yellow</td>
<td>4</td>
<td>0 000</td>
<td>white</td>
<td>9</td>
<td>000 000 000</td>
</tr>
</tbody>
</table>

So the ring-colors Brown-Black-Red would signify 1-0-00 or 1000 Ohms (1 kOhm). The fourth ring (if present) determines tolerance grade.

15.1.4 Capacitors (Caps)

Capacitors come in either polarized or unpolarized varieties. Typically polarized values are used when the capacitor value is bigger than 1 uF (micro-Farad). All capacitors have also a maximum rated voltage, which can be fairly low for polarized capacitors. This means that the voltage the capacitor is connected to in the circuit should be smaller than the rated voltage.

On a polarized capacitor the + side or minus side are marked with a + or a – sign. The + side must go to the higher voltage.

![Capacitor Symbols](image)
15.2 Using external MAP sensors

Many people use GM or other brand MAP sensors. These sensors output a linear 0..5V voltage when supplied by 5V.

Typically these sensors have 3 pins. One is 5V supply, one is output and one is ground. The sensors come in different ranges. Very typical are 1 bar (for normally aspirated engines) and 3 bar (for boosted applications).

15.2.1 Calibrating a 3 bar (or more) MAP sensor

Use a good tire pressure gauge to measure the air pressure in your spare tire. Remember, tire pressure gauges use gauge pressure. Lower the pressure in the tire to about 29 PSI (3.013 bar or 3.072 kg/cm^2).

Connect the tire valve to the sensor’s input port and note the output voltage. Also note the current atmospheric pressure in inHg or millibar (from a weather station or barometer).

Next measure the sensor output at normal atmospheric pressure.

For LogWorks the two points needed to set up a MAP channel (absolute pressure), calculate the absolute pressures as follows:

For PSIa:

\[ \text{PSIa} = \text{atmospheric pressure (in inHg)} \times 0.491 + \text{measured pressure (in PSI)} \]

For kPa:

\[ \text{kPa} = \text{atmospheric pressure (in millibar)} \times 0.1 + \text{measured pressure (in bar)} \times 100 \]

or

\[ \text{kPa} = \text{atmospheric pressure (in millibar)} \times 0.1 + \text{measured pressure (in kg/cm}^2) \times 98.07 \]

15.2.2 Calibrating a 1 bar MAP sensor

Calibrating a 1 bar sensor is a little more difficult than calibrating a 3 bar sensor because a convenient vacuum source is usually not available to the average user. If you have or can borrow a good vacuum gauge, it is easy.

Connect the vacuum gauge with a T connection to the manifold of the engine. Connect the MAP sensor also to this T. Run the engine at idle and note the vacuum and voltage.

Then switch the engine off. The MAP sensor will measure atmospheric pressure. Note the current atmospheric pressure in inHg or millibar.

Vacuum gauges typically measure gauge pressure in inHg or mmHg (or Torr).

For LogWorks the two points needed to set up a MAP channel (absolute pressure), calculate the absolute pressures as follows:

For PSIa:

\[ \text{PSIa} = \text{atmospheric pressure (in inHg)} \times 0.491 - \text{measured pressure (inHg)} \times 0.491 \]

For kPa:

\[ \text{kPa} = \text{atmospheric pressure (in millibar)} \times 0.1 + \text{measured pressure (in kg/cm}^2) \times 98.07 \]
kPa = atmospheric pressure (in millibar) * 0.1 - measured pressure (mmHg or Torr) * 7.5

15.3 Measuring voltages higher than 5 Volt

Because the Innovate Motorsports devices are designed for the common 0..5V sensors, their input range is limited to 0..5V.

A simple voltage divider can reduce the measured voltage by a certain ratio, determined by the divider ratio, which is in turn dependent on the values of the resistors used as divider. Alternatively a potentiometer can be used. Recommended is a 100 kOhm potentiometer. The advantage of a potentiometer is that ANY ratio can be simply dialed in. The following shows a simple potentiometer circuit:

![Potentiometer Circuit Diagram]

The 1 kOhm resistor (1/8 Watt or more) and the Zener diode (1/10 Watt or more) are for protection of the LMA-2 or LMA-3 in case the input voltage is too high and the output of the circuit exceeds 5.1V.

Potentiometers have typically 3 pins. The middle one is the slider (indicated with an arrow or pointer in the schematic). The other two can be connected either way as in the schematic.

To calibrate, connect the point “Measured Voltage” to the car battery and measure the voltage between the slider of the potentiometer and ground. Also measure the battery voltage.

The divider ratio is then:

\[
\text{Ratio} = \frac{\text{Battery voltage}}{\text{slider voltage}}
\]
15.4 Using Thermocouples

Thermocouples are nothing but two wires of different materials joined together at one end. The materials used determine the thermocouple type. The most common is Type K.

When two different metals are joined, a voltage is created at the junction. This voltage is determined by the temperature gradient along the wires and by the metals used. That’s why only wires of the same materials as the two thermocouple sides should be used. The voltage is very small (in the microVolt range). Therefore it has to be amplified. Also the voltage is dependent on the temperature gradient, meaning the temperature difference between the ends of the wire. So the temperature of the device measuring (the cold junction) has to be known. This is called cold-junction compensation. The LMA-3, TC-4 and DL-32 have thermocouple inputs and also provide the cold-junction compensation.

Inserting different metals in between thermocouple and measuring device (for example to extend the wires) should be avoided. The junction between the thermocouple wire and for example a copper wire would also create a voltage and change the readings. That’s why thermocouple wires of the right type for each side of the thermocouple must be used.

Sometimes it is necessary that multiple thermocouples have to be logged.

The following schematic uses the AD595 integrated circuit from Analog Devices. This device is a single chip thermocouple amplifier with cold-junction compensation. The device can be ordered from www.digikey.com. The circuit can measure between 0 degC (-32 degF) at 0V output and 1100 degC (2012 degF) at 5V output.
15.5 Measuring duty cycle of peak-hold injectors

Peak-Hold injectors are also called low impedance injectors. The voltage at the active pin of those injectors during an injection pulse first goes to ground (the peak phase) and then rises to 5 to 10 Volt (the hold phase). Because for the LMA-3/SSI-4/DL-32 everything above 2.5V is high, the devices can see only the peak phase in many cases, but not the hold phase. The following circuit allows the devices to be used with regular injectors as well as with peak-hold injectors.

NOTE: Some ECU’s control PH injectors in PWM mode. This means that they at first ground the injector’s active pin during the peak phase, and then rapidly switch ground on-and off during the hold phase. This circuit will NOT work for that method of control.

![Circuit Diagram]

When setting up the duty cycle measurement in LogWorks, positive duty cycle must be used compared to negative duty cycle as when the LMA-3 is directly connected to an injector.

15.6 Making a 5 Volt supply for external sensors

This simple circuit will create a stable 5V supply from a 7-30 Volt source. Max current should be about 300mA without heat sink on the regulator. 800-900mA with heat-sink.

![Circuit Diagram]

A LM340 can be used instead of an LM7805 as well. The 10uF capacitor is optional (reduces noise).
15.7 And finally, a weird one

Very often one can see small front-wheel-drive cars on the road with huge wings mounted on the trunk lid. But there’s no corresponding aerodynamic down-force device in the front. Of course, in the majority of cases the wing is there for the ‘cool factor’ because many race-cars have wings (birds do too, but birds also have no penis).

In a race car the wing creates aerodynamic down-force. The down force allows increasing cornering speed because more force is put vertically on the tires without increasing the mass of the car (which would create more side force proportionally). The aerodynamic forces created by wings and under-car aerodynamics can be very large. For example in a Formula 1 car at speed the down-force is twice the car’s weight (car could drive upside down on the underside of a road and would still stick with a force equal to its own weight).

In the above case one can only hope that these people never drive their car at speed. The down-force of that wing, extending past the end of the car, will lift the front of the car up and make it unstable and dangerous, especially in cross-wind situations.

But there is a legitimate need to measure down-force in a race car. Here’s how it can be done with the MTS:

Any performance car has front- and rear sway-bars (also called anti-roll bar). These are typically pieces of round spring steel (sometimes hollow tubes) that transfer the deflection force from the outer wheel in a corner to the inner wheel. During that deflection the center of the sway-bar stays pretty stationary because the bar is twisted. During normal suspension deflection on both wheels on the axle the bar rotates with the suspension movement.

To measure down-force, one can use the car’s suspension springs a spring-scale. To do that, fabricate a clamp-on lever that clamps to the center of the sway-bar. Use this lever to actuate a throttle position sensor (TPS) as in the following drawing:

Dimension the relationship between the clamp-on lever and the TPS’s lever such that the TPS goes through its movement range of about 90 degrees for the full suspension travel.

Then hook up the TPS sensor to 5V and measure its output voltage. Load the car up with 25 lb or 50lb sand-bags (over the axle) and record the sensor voltage for each load to calibrate your ‘spring scale’ for each axle.

Enter that table as custom lookup table in LogWorks (voltage vs. load).

Hook the TPS sensor to the LMA-2 or LMA-3 with the following circuit:
The low-pass filter created by the 12 kOhm resistor and 1000 uF capacitor will filter out most 'noise' coming from road surface irregularities.

Note for the electronically challenged:
You can use a capacitor with a higher voltage rating than 10V also..

16 Revision History

1.01 Initial release. 6-23-2008